Bug 733589 - Cannot view logs in TUI after drop to shell and return to TUI
Summary: Cannot view logs in TUI after drop to shell and return to TUI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Joey Boggs
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-26 06:37 UTC by Guohua Ouyang
Modified: 2011-12-06 19:27 UTC (History)
8 users (show)

Fixed In Version: ovirt-node-2.0.2-0.5.git83340dd.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 19:27:00 UTC


Attachments (Terms of Use)
less (16.27 KB, image/png)
2011-08-26 15:06 UTC, Guohua Ouyang
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1783 normal SHIPPED_LIVE rhev-hypervisor6 bug fix and enhancement update 2011-12-06 15:10:54 UTC

Description Guohua Ouyang 2011-08-26 06:37:15 UTC
Description of problem:
Drop to shell and return to TUI, then view logs, it's empty and cannot quit the process.

Version-Release number of selected component (if applicable):
rhev-hypervisor-6.2-0.14

How reproducible:
100%.

Steps to reproduce:
1. Drop to shell.
2. Type "setup" return to TUI.
3. Press F2 to view logs.

Actual results:
log content display empty and cannot quit the process.

Expected results:
View log successful.

Additional info:
In a fresh install rhevh, login with admin and press F2 to view log files, can also meet this issue sometimes. but drop to shell and return to TUI will reproduce this issue 100%

Comment 2 Mike Burns 2011-08-26 13:04:09 UTC
I tried this with upgraded 6.2-0.12 to 6.2-0.14 vm and did not encounter this problem.  

Are there any log files or stack traces?

Comment 3 Mike Burns 2011-08-26 14:13:23 UTC
Talked on IRC and this is reproducible when you've manually run the "setup" command.

1.  boot node
2.  login as admin
3.  F2
4.  view log file -- works
5.  drop to shell
6.  exit
7.  view logs -- works
8.  drop to shell
9.  setup
10.  F2
11.  view logs -- fails

QE will try to reproduce without running setup

If it's just running setup, then perhaps we should disallow running setup manually?  I don't see a use case for running setup manually

Comment 5 Guohua Ouyang 2011-08-26 15:06:48 UTC
Created attachment 520106 [details]
less

Did some testing:
1. fresh install rhevh
2. login with admin
3. view log is fine
4. drop to shell and exit, view log is fine
5. drop to shell and run setup, view log hit the issue.
so only manually run setup have this issue.

Another testing is:
1. fresh install rhevh
2. login with admin
3. drop to shell.
4. #less /var/log/ovirt.log, screen is mess, see attachment.

Comment 10 Guohua Ouyang 2011-09-06 05:54:47 UTC
Tested on 6.2-0.15:
drop to shell and manual run "setup", it display "Unable to run setup manually, Run \"exit\" to return to setup" now, this is ok.

But `less /var/log/ovirt.log` also display "Unable to run setup manually, Run \"exit\" to return to setup", this should be still a problem.

Comment 13 Guohua Ouyang 2011-09-13 02:28:37 UTC
Verified on 6.2-0.16.2:
1. view logs is ok after press F10.
2. drop to shell, `less /var/log/ovirt.log` is ok.
3. drop to shell, manual run "setup" is prevented and given a proper warning.

Comment 14 errata-xmlrpc 2011-12-06 19:27:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1783.html


Note You need to log in before you can comment on or make changes to this bug.