Bug 733597 - sending a bad keycode to guest can crash libvirt
Summary: sending a bad keycode to guest can crash libvirt
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Daniel Veillard
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-26 07:43 UTC by Daniel Veillard
Modified: 2011-12-06 11:27 UTC (History)
5 users (show)

Fixed In Version: libvirt-0.9.4-6.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 11:27:29 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1513 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2011-12-06 01:23:30 UTC

Description Daniel Veillard 2011-08-26 07:43:38 UTC
Description of problem:
Sending a bad keycode with virsh send-key can cause segmentation fault in libvirt.

% virsh send-key --codeset win32 12
   error: End of file while reading data: Input/output error

This is caused by overrun at scanning keycode array.

https://www.redhat.com/archives/libvir-list/2011-August/msg00942.html

Version-Release number of selected component (if applicable):


How reproducible:
seems systematic

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Daniel Veillard 2011-08-26 07:45:13 UTC
Upstream patch 9f5afc732c5f5b790f1c1006d2d97adb3fa7bb30

Daniel

Comment 3 Vivian Bian 2011-08-26 08:36:12 UTC
reproduced this bug with libvirt-0.9.4-5 

Steps
[root@dhcp-93-106 pkgs]# virsh send-key rhel6 --codeset win32 12
error: End of file while reading data: Input/output error

[root@dhcp-93-106 pkgs]# virsh list
error: Failed to reconnect to the hypervisor
error: no valid connection
error: Failed to connect socket to '/var/run/libvirt/libvirt-sock': Connection refused

[root@dhcp-93-106 pkgs]# service libvirtd status
libvirtd dead but pid file exists

Comment 5 dyuan 2011-08-30 09:46:47 UTC
Verified this bug PASS with libvirt-0.9.4-6.el6.

Comment 6 errata-xmlrpc 2011-12-06 11:27:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1513.html


Note You need to log in before you can comment on or make changes to this bug.