Bug 733616 - showmount -e doesn't show all the hostnames
Summary: showmount -e doesn't show all the hostnames
Keywords:
Status: CLOSED DUPLICATE of bug 726112
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nfs-utils
Version: 6.1
Hardware: ppc64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Steve Dickson
QA Contact: yanfu,wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-26 09:49 UTC by Bejoy C Alias
Modified: 2011-09-15 18:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-15 18:48:07 UTC


Attachments (Terms of Use)
The upstream patch which fixes this issue (899 bytes, patch)
2011-09-13 15:44 UTC, Steve Dickson
no flags Details | Diff

Description Bejoy C Alias 2011-08-26 09:49:49 UTC
Description of problem:
If I export an NFS patch using the exportfs command and does export of the same path for multiple hosts with multiple exportfs commands, the showmount -e output shows only the hostname of the last export.

Version-Release number of selected component (if applicable):
RHEL 6.1
nfs4-acl-tools-0.3.3-5.el6.ppc64
nfs-utils-lib-1.1.5-3.el6.ppc64
nfs-utils-1.2.3-7.el6.ppc64

How reproducible:
Always

Steps to Reproduce:
1. Export a path by running 
exportfs -i -o ro,sync,insecure,no_root_squash,no_all_squash hostname1:/mynfsshare
2. Export the same path to few other hosts by running
exportfs -i -o ro,sync,insecure,no_root_squash,no_all_squash hostname2:/mynfsshare
3. Run showmount -e , the output shows only the last host to which it was exported.
/mynfspath      hostname2
Though the mount works fine from all the exported hosts.
  
Actual results:
showmount -e shows only the last hostname in the export list.

Expected results:
showmount -e should show all the hostnames to which the path has been exported.

Additional info:

Comment 2 Steve Dickson 2011-09-13 15:44:35 UTC
Created attachment 522952 [details]
The upstream patch which fixes this issue

Comment 3 Steve Dickson 2011-09-13 18:21:10 UTC

*** This bug has been marked as a duplicate of bug 726112 ***

Comment 4 Bejoy C Alias 2011-09-14 07:18:18 UTC
Does it mean that this patch will be part of next RHEL 6 update ? or how do I fix this issue ? Need to wait till next update release ? 

And I do not have access to the duplicate bug Id mentioned 726112.

Comment 5 Bejoy C Alias 2011-09-15 14:20:28 UTC
Does it mean that this patch will be part of next RHEL 6 update ? or how do I
fix this issue ? Need to wait till next update release ? 

And I do not have access to the duplicate bug Id mentioned 726112.

Comment 6 Steve Dickson 2011-09-15 18:48:07 UTC
(In reply to comment #5)
> Does it mean that this patch will be part of next RHEL 6 update ? 
Yes. The fix for this bz is scheduled for update release 6.2

> how do I fix this issue ? Need to wait till next update release ?
You can either apply this patch to your rpm:
    http://www.spinics.net/lists/linux-nfs/msg23113.html
(basically 3 lines from  insert_group() in mount.c)
or wait for the update... The beta release of 6.2 will be
out in around three weeks.

> 
> And I do not have access to the duplicate bug Id mentioned 726112.
Its because is a partner bz. If I would've realized that, I would of 
duped their bz, which would have left this one open....

*** This bug has been marked as a duplicate of bug 726112 ***


Note You need to log in before you can comment on or make changes to this bug.