Bug 73366 - Perl built with LFS support, Apache without
Perl built with LFS support, Apache without
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: mod_perl (Show other bugs)
8.0
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-03 11:36 EDT by Joe Orton
Modified: 2007-03-26 23:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 10:16:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2002-09-03 11:36:02 EDT
Perl is compiled with LFS enabled, and uses a 64-bit "off_t"; Apache is compiled
without LFS, so uses a 32-bit off_t. The impact of this problem seems
surprisingly (but thankfully) limited, there is one reference to it in
docs/api/mod_perl-2.0/APR/PerlIO.pod:
 
             seek($fh, $offset, $whence);

           If "$offset" is zero, "seek()" works normally.

           However if "$offset" is non-zero and Perl has been
           compiled with with large files support ("-Duselarge-
           files"), whereas APR wasn't, this function will croak.
           This is because largefile size "Off_t" simply cannot
           fit into a non-largefile size "apr_off_t".

I don't expect there is much we can do about this, but worth noting the problem.
Comment 1 Bill Nottingham 2006-08-07 13:12:58 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 2 Bill Nottingham 2006-10-18 10:16:11 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.