Bug 733700 - SELinux is preventing /lib/udev/iphone-set-info from 'getattr' accesses on the file /root/.config/libimobiledevice/libimobiledevicerc.
Summary: SELinux is preventing /lib/udev/iphone-set-info from 'getattr' accesses on th...
Keywords:
Status: CLOSED DUPLICATE of bug 733687
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:5f0c1fa5b75542af7d00f815d43...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-26 14:35 UTC by dario
Modified: 2011-08-26 17:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-26 17:59:36 UTC


Attachments (Terms of Use)

Description dario 2011-08-26 14:35:37 UTC
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.0.0-1.fc16.x86_64
reason:         SELinux is preventing /lib/udev/iphone-set-info from 'getattr' accesses on the file /root/.config/libimobiledevice/libimobiledevicerc.
time:           Fri Aug 26 10:00:44 2011

description:
:SELinux is preventing /lib/udev/iphone-set-info from 'getattr' accesses on the file /root/.config/libimobiledevice/libimobiledevicerc.
:
:*****  Plugin restorecon (99.5 confidence) suggests  *************************
:
:If you want to fix the label. 
:/root/.config/libimobiledevice/libimobiledevicerc default label should be config_home_t.
:Then you can run restorecon.
:Do
:# /sbin/restorecon -v /root/.config/libimobiledevice/libimobiledevicerc
:
:*****  Plugin catchall (1.49 confidence) suggests  ***************************
:
:If you believe that iphone-set-info should be allowed getattr access on the libimobiledevicerc file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep iphone-set-info /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:udev_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:gconf_home_t:s0
:Target Objects                /root/.config/libimobiledevice/libimobiledevicerc
:                              [ file ]
:Source                        iphone-set-info
:Source Path                   /lib/udev/iphone-set-info
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           libgpod-0.8.2-1.fc16
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-15.fc16
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.0.0-1.fc16.x86_64 #1 SMP Fri
:                              Jul 22 16:09:29 UTC 2011 x86_64 x86_64
:Alert Count                   1
:First Seen                    Fri 26 Aug 2011 09:24:42 AM VET
:Last Seen                     Fri 26 Aug 2011 09:24:42 AM VET
:Local ID                      0e79a172-ffa1-4bbf-b2ea-be9eaa4c6d09
:
:Raw Audit Messages
:type=AVC msg=audit(1314366882.388:96): avc:  denied  { getattr } for  pid=7063 comm="iphone-set-info" path="/root/.config/libimobiledevice/libimobiledevicerc" dev=sda8 ino=157165 scontext=system_u:system_r:udev_t:s0-s0:c0.c1023 tcontext=system_u:object_r:gconf_home_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1314366882.388:96): arch=x86_64 syscall=fstat success=yes exit=0 a0=4 a1=7fff7c7fdfa0 a2=7fff7c7fdfa0 a3=1 items=0 ppid=1 pid=7063 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=iphone-set-info exe=/lib/udev/iphone-set-info subj=system_u:system_r:udev_t:s0-s0:c0.c1023 key=(null)
:
:Hash: iphone-set-info,udev_t,gconf_home_t,file,getattr
:
:audit2allow
:
:#============= udev_t ==============
:allow udev_t gconf_home_t:file getattr;
:
:audit2allow -R
:
:#============= udev_t ==============
:allow udev_t gconf_home_t:file getattr;
:

Comment 1 Daniel Walsh 2011-08-26 17:59:36 UTC

*** This bug has been marked as a duplicate of bug 733687 ***


Note You need to log in before you can comment on or make changes to this bug.