Bug 733732 - SELinux is preventing /usr/sbin/lldpad (deleted) from using the 'sys_module' capabilities.
Summary: SELinux is preventing /usr/sbin/lldpad (deleted) from using the 'sys_module' ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:8abf41fd77118b4b216e2a653ac...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-26 16:20 UTC by dario
Modified: 2011-09-13 06:08 UTC (History)
3 users (show)

Fixed In Version: selinux-policy-3.10.0-25.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-13 06:08:20 UTC


Attachments (Terms of Use)

Description dario 2011-08-26 16:20:43 UTC
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.0.0-1.fc16.x86_64
reason:         SELinux is preventing /usr/sbin/lldpad (deleted) from using the 'sys_module' capabilities.
time:           Fri Aug 26 11:50:18 2011

description:
:SELinux is preventing /usr/sbin/lldpad (deleted) from using the 'sys_module' capabilities.
:
:*****  Plugin sys_module (99.5 confidence) suggests  *************************
:
:If you do not believe that /usr/sbin/lldpad (deleted) should be attempting to modify the kernel by loading a kernel module.
:Then a process might be attempting to hack into your system.
:Do
:contact your security administrator and report this issue.
:
:*****  Plugin catchall (1.49 confidence) suggests  ***************************
:
:If you believe that lldpad (deleted) should have the sys_module capability by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep lldpad /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:lldpad_t:s0
:Target Context                system_u:system_r:lldpad_t:s0
:Target Objects                Unknown [ capability ]
:Source                        lldpad
:Source Path                   /usr/sbin/lldpad (deleted)
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-15.fc16
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.0.0-1.fc16.x86_64 #1 SMP Fri
:                              Jul 22 16:09:29 UTC 2011 x86_64 x86_64
:Alert Count                   1
:First Seen                    Fri 26 Aug 2011 11:48:30 AM VET
:Last Seen                     Fri 26 Aug 2011 11:48:30 AM VET
:Local ID                      f266e886-32f4-4f8c-8fb1-156f6ea3bfe1
:
:Raw Audit Messages
:type=AVC msg=audit(1314375510.720:181): avc:  denied  { sys_module } for  pid=808 comm="lldpad" capability=16  scontext=system_u:system_r:lldpad_t:s0 tcontext=system_u:system_r:lldpad_t:s0 tclass=capability
:
:
:type=SYSCALL msg=audit(1314375510.720:181): arch=x86_64 syscall=ioctl success=no exit=ENODEV a0=a a1=8913 a2=7fff195e30c0 a3=40 items=0 ppid=1 pid=808 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=lldpad exe=2F7573722F7362696E2F6C6C64706164202864656C6574656429 subj=system_u:system_r:lldpad_t:s0 key=(null)
:
:Hash: lldpad,lldpad_t,lldpad_t,capability,sys_module
:
:audit2allow
:
:#============= lldpad_t ==============
:allow lldpad_t self:capability sys_module;
:
:audit2allow -R
:
:#============= lldpad_t ==============
:allow lldpad_t self:capability sys_module;
:

Comment 1 Daniel Walsh 2011-08-26 21:53:22 UTC
You can ignore.  I added

ifdef(`hide_broken_symptoms',`
	# caused by some bogus kernel code
	dontaudit lldpad_t self:capability sys_module;
')

To 

selinux-policy-3.10.0-22.fc16

Comment 2 Fedora Update System 2011-09-08 08:05:03 UTC
selinux-policy-3.10.0-25.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/selinux-policy-3.10.0-25.fc16

Comment 3 Fedora Update System 2011-09-08 20:51:22 UTC
Package selinux-policy-3.10.0-25.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.10.0-25.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/selinux-policy-3.10.0-25.fc16
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2011-09-13 06:07:44 UTC
selinux-policy-3.10.0-25.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.