Bug 733810 - Package cleanups removed way too many packages
Package cleanups removed way too many packages
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-26 19:50 EDT by Zdenek Kabelac
Modified: 2015-02-17 08:51 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 08:51:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zdenek Kabelac 2011-08-26 19:50:55 EDT
Description of problem:

Ok - I suppose this BZ would not be the best, since I've only symptoms - but I'll try to add more debug log once this happens again.

What happened to me is - yum upgrade has crashed during its transaction process 
(see Bug 732426 for reason) - after such transaction interrupted - I've tried to use  yum-complete-transaction - this was unable to do anything and probably for fun it's been computing this decisions more then 10 minutes! and as a result suggest to remove yum!.

So then I've tried package-cleanup --cleanupdupes - 
This really remove dupes - but also a lots of other package which were not duplicated at all - thus halve of my system has been squashed -  this is really UNEXPECTED and untolerable behaviour.

If the tall want to remove package which is not duplicate - I'd strongl prefer to be informed about such choice - and also I'd like to see option to really only remove dupes - and nothing else!

Version-Release number of selected component (if applicable):
yum-utils-1.1.31-2.fc17.noarch

How reproducible:


Steps to Reproduce:
1. kill -9 some larger  yum upgrade  (like 700 packages)  somewhere in the middle of this process.
2. try to fix the machine by removing installed dupes.
3. watch out for packages which should stay in the system.
  
Actual results:


Expected results:


Additional info:
Comment 1 Zdenek Kabelac 2013-02-04 04:18:04 EST
I'm curious if this IMHO serious issue gets ever fixed ?

Today - I'd to break a transaction of yum upgrade - after installing couple texlive packages.

Then - after next run of 'yum upgrade' - I've got warning to run  yum-complete-transaction -  so I did that (and it has took at least 15 minutes to finish transaction log not doing anything useful except telling me I should remove duplicate packages.

So again I did what the tool said - I've executed:
  'package-cleanup --cleandupes'

Oh boy - it has wanted to remove  some texlive packages and also
some libreoffice one -  since I'd not carefully watched what has been
previously installed (to much logging output) - I've confirmed this operation.

After that - well there was no duplicated texlive package - but also no libreoffice....

So it looks like tools needs to have an option to keep an older version of the package if it prevents removing of packages unrelated to the transaction - there was likely no duplicate libreoffice package installed yet.
(And especially if there are (for non-understandable reason) strong deps of libreoffice package to the exact version of texlive??)


Removing:
 libreoffice-ure                         x86_64               1:4.0.0.0-2.beta1.fc19                                @rawhide               8.2 M
 texlive-amsmath                         noarch               2:svn26389.2.13-14.fc19                               @rawhide               174 k
 texlive-base                            noarch               2:2012-14.20130102_r28692.fc19                        @rawhide               6.3 M
 texlive-graphics                        noarch               2:svn25405.1.0o-14.fc19                               @rawhide                78 k
 texlive-hyphen-base                     noarch               2:svn28531.0-14.fc19                                  @rawhide                62 k
 texlive-kpathsea                        noarch               2:svn28617.0-14.fc19                                  @rawhide               214 k
 texlive-kpathsea-bin                    x86_64               2:svn27347.0-14.20130102_r28692.fc19                  @rawhide                71 k
 texlive-kpathsea-lib                    x86_64               2:2012-14.20130102_r28692.fc19                        @rawhide               132 k
 texlive-tetex                           noarch               2:svn28616.3.0-14.fc19                                @rawhide               265 k
 texlive-tetex-bin                       noarch               2:svn27344.0-14.20130102_r28692.fc19                  @rawhide               0.0  
 texlive-tools                           noarch               2:svn26263.0-14.fc19                                  @rawhide               229 k
 texlive-xkeyval                         noarch               2:svn27995.2.6a-14.fc19                               @rawhide                49 k
Removing for dependencies:
 libreoffice-base                        x86_64               1:4.0.0.0-2.beta1.fc19                                @rawhide               6.5 M
 libreoffice-calc                        x86_64               1:4.0.0.0-2.beta1.fc19                                @rawhide                24 M
 libreoffice-core                        x86_64               1:4.0.0.0-2.beta1.fc19                                @rawhide               220 M
 libreoffice-draw                        x86_64               1:4.0.0.0-2.beta1.fc19                                @rawhide               2.2 M
 libreoffice-graphicfilter               x86_64               1:4.0.0.0-2.beta1.fc19                                @rawhide               1.2 M
 libreoffice-impress                     x86_64               1:4.0.0.0-2.beta1.fc19                                @rawhide               4.2 M
 libreoffice-langpack-cs                 x86_64               1:4.0.0.0-2.beta1.fc19                                @rawhide                25 M
 libreoffice-math                        x86_64               1:4.0.0.0-2.beta1.fc19                                @rawhide               3.2 M
 libreoffice-ogltrans                    x86_64               1:4.0.0.0-2.beta1.fc19                                @rawhide               228 k
 libreoffice-pdfimport                   x86_64               1:4.0.0.0-2.beta1.fc19                                @rawhide               633 k
 libreoffice-writer                      x86_64               1:4.0.0.0-2.beta1.fc19                                @rawhide                16 M
 libreoffice-xsltfilter                  x86_64               1:4.0.0.0-2.beta1.fc19                                @rawhide               1.9 M


Version-Release number of selected component (if applicable):
yum-utils-1.1.31-9.fc19.noarch
Comment 2 Fedora End Of Life 2013-04-03 13:36:56 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora19
Comment 3 Fedora End Of Life 2015-01-09 11:45:44 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 4 Fedora End Of Life 2015-02-17 08:51:24 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.