Bug 733884 - chkconfig errors during %post - wrong service names
Summary: chkconfig errors during %post - wrong service names
Keywords:
Status: CLOSED DUPLICATE of bug 685155
Alias: None
Product: Fedora
Classification: Fedora
Component: openstack-swift
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Silas Sewell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-28 09:37 UTC by Mark McLoughlin
Modified: 2011-10-17 10:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-17 10:38:44 UTC


Attachments (Terms of Use)

Description Mark McLoughlin 2011-08-28 09:37:14 UTC
The service is called openstack-swift-account, but %post does e.g.

  %post account
  /sbin/chkconfig --add swift-account

so you get:

  Installing : openstack-swift-account-1.4.0-2.fc16.noarch
  Non-fatal POSTIN scriptlet failure in rpm package openstack-swift-account-1.4.0-2.fc16.noarch
  error reading information on service swift-account: No such file or directory
  warning: %post(openstack-swift-account-1.4.0-2.fc16.noarch) scriptlet failed

Comment 1 Mark McLoughlin 2011-10-17 10:38:44 UTC

*** This bug has been marked as a duplicate of bug 745951 ***

Comment 2 Mark McLoughlin 2011-10-17 10:39:59 UTC

*** This bug has been marked as a duplicate of bug 685155 ***


Note You need to log in before you can comment on or make changes to this bug.