Bug 733897 - [system-config-printer] suggested driver for HP LaserJet 4000 is CUPS+Gutenprint
Summary: [system-config-printer] suggested driver for HP LaserJet 4000 is CUPS+Gutenprint
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-28 12:12 UTC by Joachim Frieben
Modified: 2011-12-05 12:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-05 12:50:16 UTC


Attachments (Terms of Use)
Output of 'system-config-printer --debug' for HP LaserJet 4000 at /dev/lp0. (12.52 KB, text/plain)
2011-08-28 12:13 UTC, Joachim Frieben
no flags Details
HP-LaserJet-4000.ppd configuration file. (78.78 KB, text/plain)
2011-08-28 12:14 UTC, Joachim Frieben
no flags Details

Description Joachim Frieben 2011-08-28 12:12:16 UTC
Description of problem:
After installing F15 from a fully updated live CD, system-config-printers suggest driver CUPS+Gutenprint for an HP LaserJet 4000 connected to the system by means of the parallel port /dev/lp0.

Version-Release number of selected component (if applicable):
system-config-printer-1.3.5-3.fc15

How reproducible:
Always.

Steps to Reproduce:
1. Install a fully up-to-date F15 from a current live spin.
2. Run s-c-p to install an HP LaserJet 4000 N connected via dev/lp0.
  
Actual results:
s-c-p suggests CUPS+Gutenprint as recommended driver.

Expected results:
Standard driver is the Postscript one.

Additional info:
None.

Comment 1 Joachim Frieben 2011-08-28 12:13:36 UTC
Created attachment 520218 [details]
Output of 'system-config-printer --debug' for HP LaserJet 4000 at /dev/lp0.

Comment 2 Joachim Frieben 2011-08-28 12:14:30 UTC
Created attachment 520219 [details]
HP-LaserJet-4000.ppd configuration file.

Comment 3 Tim Waugh 2011-08-30 10:11:55 UTC
What does the command '/usr/lib/cups/backend/parallel' say when you run it as root with the printer connected and powered on?

Comment 4 Joachim Frieben 2011-08-30 12:59:59 UTC
(In reply to comment #3)
$ /usr/lib/cups/backend/parallel
direct parallel:/dev/lp0 "HP LaserJet 4000 Series" "HP LaserJet 4000 Series LPT #1" "MANUFACTURER:Hewlett-Packard;COMMAND SET:PJL,MLC,PCL,PCLXL,POSTSCRIPT;MODEL:HP LaserJet
 4000 Series;CLASS:PRINTER;DESCRIPTION:Hewlett-Packard LaserJet 4000 Series" ""

Comment 6 Tim Waugh 2011-12-05 12:50:16 UTC
I can't reproduce this now with:

system-config-printer-1.3.5-3.fc15
hplip-3.11.10-5.fc15
foomatic-db-4.0-28.20110221.fc15
gutenprint-cups-5.2.7-3.fc15

Do you still see it?  If so, please re-open this report.


Note You need to log in before you can comment on or make changes to this bug.