Bug 733909 - [vdsm][storage]getSpmStatus returns invalid spmId
Summary: [vdsm][storage]getSpmStatus returns invalid spmId
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Saggi Mizrahi
QA Contact: Moran Goldboim
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-28 14:09 UTC by Moran Goldboim
Modified: 2011-12-06 07:25 UTC (History)
8 users (show)

Fixed In Version: vdsm-4.9-97.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 07:25:57 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:1782 normal SHIPPED_LIVE new packages: vdsm 2011-12-06 11:55:51 UTC

Description Moran Goldboim 2011-08-28 14:09:20 UTC
Description of problem:
getSpmStatus is returned from cache which might be wrong - faced a problem with it when rhevm goes up and doesn't know which is the SPM, he sends getSpmStatus to a random host in the cluster and based on the spmId from the result tries that host for spm, since the spmId is wrong rhevm fails and looks for additional host - which may take a long time on a large scaled env.

Version-Release number of selected component (if applicable):
vdsm-4.9-91.el6.x86_64

How reproducible:


Steps to Reproduce:
1.restart vdsm on spm
2.let other host take spm
3.run getSpmStatus on old spm
  
Actual results:
when rhevm goes up it tries to take spm using multiple hosts - and get resource acquire timeout. 

Expected results:


Additional info:
running on host id 89 - vdsm says that spm runs on hostId 89 and free...
[root@dhcp151-128 ~]# vdsClient -s 0 getSpmStatus e505624e-c8af-11e0-96a0-03e8c0272e3a
        spmId = 89
        spmStatus = Free
        spmLver = 4

Comment 2 Saggi Mizrahi 2011-08-29 07:45:07 UTC
http://gerrit.usersys.redhat.com/#change,860

Comment 4 Daniel Paikov 2011-09-22 11:29:59 UTC
Checked on 4.9-104.

Comment 7 errata-xmlrpc 2011-12-06 07:25:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1782.html


Note You need to log in before you can comment on or make changes to this bug.