Bug 73401 - PREFIX not used in Makefiles generated by perl
Summary: PREFIX not used in Makefiles generated by perl
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl   
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-04 07:48 UTC by Gerald Teschl
Modified: 2007-04-18 16:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-11 11:11:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gerald Teschl 2002-09-04 07:48:16 UTC
make-3.79.1-14

I just tried to rebuild some rpms created with cpanflute2 and noted that
all will fail (they build fine under 7.3).

I noted that the problem is that the command

make PREFIX=..... install

does not install the files under the PREFIX given on the command line
but under the PREFIX given in the Makefile.

Comment 1 Christof Damian 2002-10-16 13:15:01 UTC
also: is there a cpanflute available for redhat 8.0 ?

Comment 2 Gerald Teschl 2003-01-19 16:44:42 UTC
The problem is that the Makefile generated by perl from Makefile.PL
has a PREFIX varibale but it is not used. E.g., it has

PREFIX=/usr
INSTALLVENDORLIB=/usr/lib/perl5/vendor_perl/5.8.0

instaed of

PREFIX=/usr
INSTALLVENDORLIB=$(PREFIX)/lib/perl5/vendor_perl/5.8.0

As a consequence

perl Makefile.PL
make
PREFIX=$RPM_BUILD_ROOT/usr make install

will no longer work. However,

perl Makefile.PL PREFIX=$RPM_BUILD_ROOT/usr
make
make install

will work.

This change breaks all rpms made with cpanflute.

Comment 3 Christof Damian 2003-01-19 17:41:40 UTC
to answer my own question: on CPAN you can find RPM::Specfile which includes
cpanflute2 which works nicely with redhat 8.0.


Note You need to log in before you can comment on or make changes to this bug.