Bug 734105 - tsclient can't import/export with space in import/export file name
Summary: tsclient can't import/export with space in import/export file name
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tsclient
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Ondrej Holy
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-29 13:23 UTC by Martin Simon
Modified: 2016-09-20 02:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-15 09:44:25 UTC


Attachments (Terms of Use)

Description Martin Simon 2011-08-29 13:23:40 UTC
Description of problem:
tsclient can't export connection to file with space or # in name. It can't import from file with space or # neither. 

Version-Release number of selected component (if applicable):
tsclient-2.0.2-7.el6.x86_64


How reproducible:
100%

Steps to Reproduce:
1. start tsclient from terminal (you will see runtime messages/commands)
2. import/export any connection to file with space or # in name
3.
  
Actual results:
tsclient doesn't tell anything if he succeed or not, but in terminal you can see tar error messages

Expected results:
connection is imported/exported successfully without any error messages

Additional info:
it looks like bad integration with tar, maybe missing quotes in tar command
tar version: tar-1.23-3.el6.x86_64

Comment 2 RHEL Product and Program Management 2011-10-07 16:10:31 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 4 Suzanne Yeghiayan 2012-02-14 23:14:46 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 6 Ondrej Holy 2015-10-05 11:37:14 UTC
(In reply to Martin Simon from comment #0)
> (snip)
> 
> Additional info:
> it looks like bad integration with tar, maybe missing quotes in tar command
> tar version: tar-1.23-3.el6.x86_64

Indeed, there are missing quotes...

g_string_append_printf (cmdline, "tar cfz %s --directory %s --remove-files ", absfile, export_dir);

cmdline = g_strdup_printf ("tar xfz %s -C %s", absfile, import_dir_path);

Comment 8 Mike McCune 2016-03-28 23:14:23 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions


Note You need to log in before you can comment on or make changes to this bug.