Bug 73415 - rpm-4.1 hangs: concurrent access deadlock
rpm-4.1 hangs: concurrent access deadlock
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-04 08:25 EDT by Joe Orton
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-12 11:26:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2002-09-04 08:25:55 EDT
Using Psyche-0903.2, rpm-4.1-1.05, I have an RPM hang during a package upgrade:

[root@host240 RPMS]# rpm -Uvh mod_auth_mysql-1.11-10.i386.rpm
mod_auth_pgsql-0.9.12-11.i386.rpm mysql-3.23.52-2.i386.rpm
perl-DBD-MySQL-2.1017-3.i386.rpm 
warning: mod_auth_mysql-1.11-10.i386.rpm: V3 DSA signature: NOKEY, key ID db42a60e
Preparing...                ########################################### [100%]
   1:mod_auth_pgsql         ########################################### [ 25%]
<hung>

The process is stuck doing:

select(0, NULL, NULL, NULL, {1, 0})     = 0 (Timeout)
select(0, NULL, NULL, NULL, {1, 0})     = 0 (Timeout)
Comment 1 Joe Orton 2002-09-04 08:31:24 EDT
Oh, it looks like I had stupidly run rpmq as root during this update, so I guess
this is covered by the catch-all RPM hangs bug... sorry.
Comment 2 Jeff Johnson 2002-09-17 08:36:46 EDT
OK, this smells like a real concurrency deadlock,
so I'm gonna turn this into a category bug.
Comment 3 Boris Folgmann 2003-03-12 11:23:53 EST
I have the same problem. It happens very often when installing or upgrading a
rpm.  Only kill -9 can remove the hanging rpm process. I don't have any
concurrent rpm queries. Could it be a problem with rhn?
Comment 4 Jeff Johnson 2003-03-12 11:26:16 EST
Time to close this category bug as well.

Try rpm-4.1.1 packages from
    ftp://ftp.rpm.org/pub/rpm/test-4.1.1

Note You need to log in before you can comment on or make changes to this bug.