Bug 734185 - error downloading: http://download.fedoraproject.org/pub/epel/4/i386/headers/nagios-0-2.12-9.el4.i386.hdr
Summary: error downloading: http://download.fedoraproject.org/pub/epel/4/i386/headers/...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: nagios
Version: el4
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Peter Lemenkov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-29 16:31 UTC by Jay Libove
Modified: 2011-12-17 15:52 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-17 14:06:56 UTC


Attachments (Terms of Use)
/var/log/up2date as referenced in error output from up2date command (24.64 KB, application/octet-stream)
2011-08-29 16:31 UTC, Jay Libove
no flags Details

Description Jay Libove 2011-08-29 16:31:04 UTC
Created attachment 520428 [details]
/var/log/up2date as referenced in error output from up2date command

Description of problem:
With EPEL-4 enabled on an RHEL-4 system, some 'up2date' attempts fail with header download errors relating to a(n apparently totally unrelated?!) header file for nagios, e.g.:

# up2date cyrus-imapd-utils

Fetching Obsoletes list for channel: rhel-i386-es-4...

Fetching Obsoletes list for channel: dag...

Fetching Obsoletes list for channel: EPEL...

Fetching rpm headers...
########################################

Name                                    Version              Rel               Arch
----------------------------------------------------------------------------------------
cyrus-imapd-utils                       2.2.12              15.el4              i386  


Testing package set / solving RPM inter-dependencies...

Downloading headers to solve dependencies...
There was an error downloading: http://download.fedoraproject.org/pub/epel/4/i386/headers/nagios-0-2.12-9.el4.i386.hdr
There was an error downloading: http://download.fedoraproject.org/pub/epel/4/i386/headers/nagios-0-2.12-9.el4.i386.hdr
There was an error downloading: http://download.fedoraproject.org/pub/epel/4/i386/headers/nagios-0-2.12-9.el4.i386.hdr
There was an error downloading: http://download.fedoraproject.org/pub/epel/4/i386/headers/nagios-0-2.12-9.el4.i386.hdr
There was an error downloading: http://download.fedoraproject.org/pub/epel/4/i386/headers/nagios-0-2.12-9.el4.i386.hdr
An error has occurred:
exceptions.UnboundLocalError
See /var/log/up2date for more information

Version-Release number of selected component (if applicable):
Unknown; as far as I can tell, the current version of the nagios component for which up2date reports it cannot download a header file is actually 2.12.-10 (I guess this from looking at what files are available in an FTP listing of an EPEL-4 repository).

How reproducible:
How to get a system in to this situation in the first place, I do not know. On this particular system, simply having the EPEL 4 line added to the RHN sources file:

 yum EPEL http://download.fedoraproject.org/pub/epel/4/$ARCH

is enough to cause it.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Header download error above.

Expected results:
Normal up2date'ing.

Additional info:
/var/log/up2date file attached.

Comment 1 Peter Lemenkov 2011-09-22 11:48:24 UTC
Can't reproduce because I don't have any EL-4 boxes anymore. Is this issue still valid?

Comment 2 Jay Libove 2011-12-17 15:52:31 UTC
Hi Peter. I was able to work around it, with substantial waste of time, and not consistently. At the moment, I do not have the problem, and of course hopefully I will soon not have any more RHEL4 boxes around either...


Note You need to log in before you can comment on or make changes to this bug.