Bug 734235 - Cannot uninstall nfs-utils 1.0.9, scriptlet failed
Summary: Cannot uninstall nfs-utils 1.0.9, scriptlet failed
Keywords:
Status: CLOSED DUPLICATE of bug 729603
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nfs-utils
Version: 5.7
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: rc
: ---
Assignee: Steve Dickson
QA Contact: yanfu,wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-29 19:57 UTC by Michael Worsham
Modified: 2018-11-14 10:32 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-28 19:38:34 UTC


Attachments (Terms of Use)
Screenshot of nfs-util uninstall failure (40.14 KB, image/png)
2011-08-29 20:07 UTC, Michael Worsham
no flags Details
Additional screenshot using 'yum' to attempt uninstall (50.54 KB, image/png)
2011-09-14 19:56 UTC, Michael Worsham
no flags Details

Description Michael Worsham 2011-08-29 19:57:46 UTC
Description of problem:
Attempted to do a 'yum update' and download/install new RHEL5 updates. Found that the server kept hanging on the nfs-utils package. Breaking out of yum shows the error (as seen below). Tried removing the package manually using the rpm -e command and kept encountering the same error:

error: %preun(nfs-utils-1.0.9-50.el5.x86_64) scriptlet failed, signal 2

Version-Release number of selected component (if applicable):
1.0.9-50

How reproducible:
Always

Steps to Reproduce:
1. yum remove nfs-utils
2. rpm -e nfs-utils
3.
  
Actual results:
Shows it attempting on shutting down NFS daemon processes, even if they aren't running. Then hangs after that point on.

Comment 1 Michael Worsham 2011-08-29 20:07:56 UTC
Created attachment 520458 [details]
Screenshot of nfs-util uninstall failure

Comment 2 Michael Worsham 2011-09-14 19:56:22 UTC
Created attachment 523248 [details]
Additional screenshot using 'yum' to attempt uninstall

Comment 4 Steve Dickson 2011-09-28 19:38:34 UTC
It appears we have two problems here

(In reply to comment #1)
> Created attachment 520458 [details]
> Screenshot of nfs-util uninstall failure

For some reason the un-exporting of the file systems failed.
Unfortunately I am unable to reproduce it plust is not all
that critical of error.  

(In reply to comment #2)
Created attachment 523248 [details]
Additional screenshot using 'yum' to attempt uninstall
This is a dup of this https://bugzilla.redhat.com/show_bug.cgi?id=729603

*** This bug has been marked as a duplicate of bug 729603 ***

Comment 5 Michael Worsham 2011-09-28 19:53:28 UTC
Small problem. I cannot open/access bug 729603.

Message Received: "You are not authorized to access bug #729603"


Note You need to log in before you can comment on or make changes to this bug.