Bug 734250 - [abrt] xsane-0.998-4.fc14: handle_error: Process /usr/bin/xsane was killed by signal 6 (SIGABRT)
Summary: [abrt] xsane-0.998-4.fc14: handle_error: Process /usr/bin/xsane was killed by...
Keywords:
Status: CLOSED DUPLICATE of bug 719745
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk2
Version: 14
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:6613739655d88ab6da5de571f0a...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-29 21:35 UTC by Jason Herring
Modified: 2011-11-14 08:53 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-14 08:53:44 UTC


Attachments (Terms of Use)
File: backtrace (54.61 KB, text/plain)
2011-08-29 21:35 UTC, Jason Herring
no flags Details

Description Jason Herring 2011-08-29 21:35:27 UTC
abrt version: 1.1.18
architecture: x86_64
Attached file: backtrace, 55919 bytes
cmdline: xsane
component: xsane
Attached file: coredump, 11804672 bytes
crash_function: handle_error
executable: /usr/bin/xsane
kernel: 2.6.35.14-95.fc14.x86_64
package: xsane-0.998-4.fc14
rating: 4
reason: Process /usr/bin/xsane was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1314653657
uid: 6669

How to reproduce
-----
1. start app
2. select scanner
3. crash soon after painting the main window

Comment 1 Jason Herring 2011-08-29 21:35:30 UTC
Created attachment 520470 [details]
File: backtrace

Comment 2 Jason Herring 2011-09-01 22:37:41 UTC
Package: xsane-0.998-4.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. removed .sane to have a clean start
2. started "Scanner Tool", and choose device dialog comes up
3. I  choose my scanner, sane begins to start, partially draws the main window then crashes


Comment
-----
Nothing special.  Does it every time.  the "Simple Scan" tool works  fine.

Comment 3 Nils Philippsen 2011-09-02 08:22:52 UTC
X11 BadMatch error, looks like a toolkit issue:

#4  0x00000030b986a356 in gdk_x_error (display=<value optimized out>, error=<value optimized out>) at gdkmain-x11.c:466
        buf = "BadMatch (invalid parameter attributes)", '\000' <repeats 24 times>
        msg = <value optimized out>

Changing component.

Comment 4 Nils Philippsen 2011-11-14 08:53:44 UTC

*** This bug has been marked as a duplicate of bug 719745 ***


Note You need to log in before you can comment on or make changes to this bug.