Bug 734291 - Graphics corruption and loss of acceleration on 845 chipset ("(EE) intel(0): Detected a hung GPU, disabling acceleration.").
Summary: Graphics corruption and loss of acceleration on 845 chipset ("(EE) intel(0): ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-intel
Version: 6.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 842499
TreeView+ depends on / blocked
 
Reported: 2011-08-30 01:56 UTC by Gideon Mayhak
Modified: 2017-12-06 12:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-06 12:27:04 UTC


Attachments (Terms of Use)
dmesg after error (28.48 KB, application/octet-stream)
2011-08-30 01:56 UTC, Gideon Mayhak
no flags Details
Xorg.0.log after error (80.30 KB, application/octet-stream)
2011-08-30 01:56 UTC, Gideon Mayhak
no flags Details

Description Gideon Mayhak 2011-08-30 01:56:30 UTC
Created attachment 520500 [details]
dmesg after error

Description of problem:
Sporadically, the screen will go black, and then come back with some corruption.  Logs indicate that acceleration has been disabled, and things like scrolling on web pages become extremely jerky.

In addition, logging off will cause the screen to go black (GDM does not reload).  You are still able to change VTs and reboot the system properly.

Version-Release number of selected component (if applicable):
kernel-2.6.32-131.12.1.el6.i686
xorg-x11-drv-intel-2.14.0-1.el6.i686

How reproducible:
It varies.  Sometimes, you're able to use the computer without glitch for quite some time.  Other times, it will happen within minutes of boot.

Steps to Reproduce:
1. Install EL 6.1 on 845-based workstation (I haven't had a chance to try 6.0, so I don't know if the behavior is the same there or not; I can try on another 845-based system if it would help narrow things down)
2. Boot into runlevel 5 with X
3. Watch it go black and corrupt the image during normal use
  
Actual results:
Corrupted graphics; disabled acceleration.

Expected results:
No issues.

Additional info:
00:02.0 VGA compatible controller [0300]: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device [8086:2562] (rev 01) (prog-if 00 [VGA controller])
        Subsystem: Dell Device [1028:0126]
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Interrupt: pin A routed to IRQ 16
        Region 0: Memory at e8000000 (32-bit, prefetchable) [size=128M]
        Region 1: Memory at ff680000 (32-bit, non-prefetchable) [size=512K]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: <access denied>
        Kernel driver in use: i915
        Kernel modules: i915

Comment 1 Gideon Mayhak 2011-08-30 01:56:55 UTC
Created attachment 520501 [details]
Xorg.0.log after error

Comment 3 Gideon Mayhak 2011-09-02 04:37:10 UTC
I went ahead and downgraded to xorg-x11-drv-intel-2.11.0-7.el6.i686 to see if that helps.  I'll let you know my findings.

Comment 4 Gideon Mayhak 2011-09-03 23:07:55 UTC
So far, it seems there are at least no errors in the logs.  However, I haven't been at the machine myself, so I can't say what the experience is like.  The main user is someone who probably won't notice as long as things are "working", but I'm assuming it's working well.

Comment 5 Gideon Mayhak 2011-09-19 23:36:43 UTC
It looks like the user's still seeing the occasional issue with the older driver, but the logs look like it's happening a lot less frequently (and might be a slightly different issue).

Comment 6 RHEL Product and Program Management 2011-10-07 16:15:09 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 7 Gideon Mayhak 2011-12-08 20:19:25 UTC
So I have found what I believe is a workaround for this.  I haven't been at the machine since I made these changes, but I don't see any of the errors that I was seeing in the logs, and the system has been up for over 9 days now.  While running the 2.11.0 version of the intel driver, I created /etc/modprobe.d/drm.conf with the following:

    options drm_kms_helper poll=0

That makes no difference running the 2.14.0 version, as the errors still occur, but that in combination with 2.11.0 seems to work.

I have purchased an AGP card for this system that I plan to install this weekend, so I'm not as concerned with this issue anymore.  However, I'll let y'all decide whether you might want to keep this open to track a future fix or not.  I can test future updates on similar systems I have at home.

Comment 8 Lyude 2015-12-18 16:17:56 UTC
Hi! It's likely that you may not even have this machine anymore but I figured it was worth a try asking anyway, do you know if this issue is still occurring on 6.7?

Comment 9 Gideon Mayhak 2017-03-20 13:41:39 UTC
I'm sorry I've been silent on this issue.  I haven't had access to a system with this hardware for several years now, and I doubt it's a valid concern anymore.

I think it's safe to close this bug.  Sorry again for being absent from Bugzilla for so long.

Comment 10 Jan Kurik 2017-12-06 12:27:04 UTC
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/


Note You need to log in before you can comment on or make changes to this bug.