Bug 734296 - ImportError: cound not import bonobo.ui
Summary: ImportError: cound not import bonobo.ui
Keywords:
Status: CLOSED DUPLICATE of bug 689836
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-python2
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Colin Walters
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-30 02:45 UTC by Akira TAGOH
Modified: 2011-10-28 16:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-28 16:53:03 UTC


Attachments (Terms of Use)

Description Akira TAGOH 2011-08-30 02:45:52 UTC
Description of problem:
When bringing audit-viewer up from the terminal, "ImportError: cound not import bonobo.ui" appears on the terminal.

Version-Release number of selected component (if applicable):
audit-viewer-0.7.2-1.fc16.x86_64

How reproducible:
always

Steps to Reproduce:
1.run audit-viewer on the terminal to see the above error clearly.
2.
3.
  
Actual results:
the above error is output on the terminal.

Expected results:
no error

Additional info:

Comment 1 Miloslav Trmač 2011-08-30 08:57:24 UTC
Reproduced, thanks for your report.

Comment 2 Miloslav Trmač 2011-08-30 09:23:29 UTC
Simpler reproducer, with gnome-python2-2.28.1-4.fc15.x86_64:
> $ python
> >>> import gnome.ui
> ImportError: could not import bonobo.ui
> >>> gnome.ui
> <module 'gnome.ui' from '/usr/lib64/python2.7/site-packages/gtk-2.0/gnome/ui.so'>

i.e. gnome.ui looks for bonobo.ui (which is presumably packaged in gnome-python2-bonobo that isn't installed); when bonobo.ui isn't installed, gnome.ui will complain on stderr and load successfully anyway.

The error message itself comes from /usr/share/pygobject/2.0/codegen/codegen.py:SourceWriter:write_object_imports.

Comment 3 Mads Kiilerich 2011-10-28 16:53:03 UTC

*** This bug has been marked as a duplicate of bug 689836 ***


Note You need to log in before you can comment on or make changes to this bug.