Bug 734301 - [zh_TW] zh_TW does not install the fonts listed on fonts list
Summary: [zh_TW] zh_TW does not install the fonts listed on fonts list
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: i18n
Version: 16
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Peng Wu
QA Contact: A S Alam
URL:
Whiteboard:
Depends On: 740454
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-30 03:16 UTC by Cheng-Chia Tseng
Modified: 2013-07-03 01:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-14 03:29:20 UTC


Attachments (Terms of Use)

Description Cheng-Chia Tseng 2011-08-30 03:16:58 UTC
Description of problem:
According to the fonts list (http://tagoh.fedorapeople.org/fonts/f15-defaultfonts.html), zh_TW should have AR PL UMing TW installed, but actually not.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. install fedora 16 Nightly in Traditional Chinese from http://dl.fedoraproject.org/pub/alt/stage/f16-translation/
2. update the system
3. download the test script from http://tagoh.fedorapeople.org/fonts/fc-test.sh

  
Actual results:
sans[zh]: wqy-zenhei.ttc: "WenQuanYi Zen Hei" "Regular"
serif[zh]: wqy-zenhei.ttc: "WenQuanYi Zen Hei" "Regular"
monospace[zh]: wqy-zenhei.ttc: "文泉驛正黑" "Regular"
sans[zh-tw]: wqy-zenhei.ttc: "WenQuanYi Zen Hei" "Regular"
serif[zh-tw]: wqy-zenhei.ttc: "WenQuanYi Zen Hei" "Regular"
monospace[zh-tw]: wqy-zenhei.ttc: "WenQuanYi Zen Hei Mono" "Regular"


Expected results:
sans[zh-tw]: AR PL UMing TW
serif[zh-tw]: AR PL UMing TW
monospace[zh-tw]: AR PL UMing TW

Additional info:

Comment 1 Peng Wu 2011-09-15 10:20:37 UTC
This is because cjkuni-uming-fonts is not installed on Fedora Live image.

Sorry, I think the above test case is for Fedora DVD on hard drive,
with "Traditional Chinese Support" package group installed.
run yum groupinstall "Traditional Chinese Support" to get the correct result.

Comment 2 Peng Wu 2011-09-15 10:35:20 UTC
Thanks for the reporting.
It reminds me to change wqy-zenhei-fonts to wqy-microhei-fonts on Fedora Live to save image space.
Changed the comps.git.

Comment 3 Cheng-Chia Tseng 2011-09-20 15:06:21 UTC
Ok, I have tested this case with Fedora DVD.

I chose "Chinese (Traditional)" as the installation language.

After installation, I ran the fc-test.sh. And the result are still the same as Live CD.

sans[zh]: wqy-zenhei.ttc: "WenQuanYi Zen Hei" "Regular"
serif[zh]: wqy-zenhei.ttc: "WenQuanYi Zen Hei" "Regular"
monospace[zh]: wqy-zenhei.ttc: "文泉驛正黑" "Regular"
sans[zh-tw]: wqy-zenhei.ttc: "WenQuanYi Zen Hei" "Regular"
serif[zh-tw]: wqy-zenhei.ttc: "WenQuanYi Zen Hei" "Regular"
monospace[zh-tw]: wqy-zenhei.ttc: "WenQuanYi Zen Hei Mono" "Regular"

The result of "rpm -q cjkuni-uming-fonts" is "套件 cjkuni-uming-fonts 尚未安裝 (package cjkuni-uming-fonts is not installed)."

Comment 4 Peng Wu 2011-09-22 05:41:51 UTC
Hi,
  I checked the Fedora 16 DVD Beta RC1 iso, and found that cjkuni-uming-fonts/cjkuni-ukai-fonts are not included in DVD image (Fedora-16-Beta-x86_64-DVD.iso).

Comment 5 Peng Wu 2011-09-22 06:03:13 UTC
Open bug #740454 - Please add back cjkuni-uming-fonts and cjkuni-ukai-fonts to DVD ISO.
Request to add back cjkuni-uming-fonts/cjkuni-ukai-fonts to DVD image.

Comment 6 Peng Wu 2011-10-13 05:42:09 UTC
cjkuni-uming-fonts is in f16-beta-rc3 DVD iso.

Comment 7 Peng Wu 2011-12-14 03:29:20 UTC
cjkuni-uming-fonts is in Fedora 16 Final. Close bug.


Note You need to log in before you can comment on or make changes to this bug.