Bug 734358 - RHEL6.2 guest desktop&screen resolution has problem when boot with spice+qxl
Summary: RHEL6.2 guest desktop&screen resolution has problem when boot with spice+qxl
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-qxl
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Søren Sandmann Pedersen
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-30 07:41 UTC by Qunfang Zhang
Modified: 2014-06-18 09:14 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-04 18:39:01 UTC


Attachments (Terms of Use)

Description Qunfang Zhang 2011-08-30 07:41:54 UTC
Description of problem:
Install a RHEL6.2 guest with the RHEL6.2-20110823.1/ tree with spice. After finish installation, can not resize client resolution to larger value, and the largest resolution is 1024x768. Another issue is on the guest login screen, the mouse will be captured by the guest. After login to guest desktop, it can move out from guest.
So check the guest related packages version, they are:
kernel-2.6.32-191.el6.x86_64
xorg-x11-drv-qxl-0.0.14-5.el6

Then I upgrade xorg-x11-drv-qxl to 0.0.14-6 and reboot guest,but guest will hang on the login screen. If system_reset it in the qemu monitor there's prompt: (qemu) system_reset 
(qemu) red_wait_outgoing_item: blocked

Guest still hang after system reset, the qemu-kvm process consumes 100% host cpu. 

Version-Release number of selected component (if applicable):
Host:
kernel-2.6.32-192.el6.x86_64
qemu-kvm-0.12.1.2-2.184.el6.x86_64
Guest:
install tree: RHEL6.2-20110823.1
kernel-2.6.32-191.el6.x86_64
xorg-x11-drv-qxl-0.0.14-5.el6.x86_64


How reproducible:
Always

Steps to Reproduce:
1.Install and boot a RHEL6.2-64 guest with spice
/usr/libexec/qemu-kvm -M rhel6.2.0 -cpu cpu64-rhel6,+x2apic  -enable-kvm -m 4096 -smp 2,sockets=2,cores=1,threads=1 -name RHEL6.2-64 -uuid 2b379603-6f73-497c-bbdc-d3dc948248e8 -monitor stdio -rtc base=localtime -boot c -device virtio-serial-pci,id=virtio-serial0,max_ports=16,bus=pci.0,addr=0x4 -drive file=/home/RHEL6.2-64.qcow2,if=none,id=ide-drive-0,format=qcow2,cache=none,werror=stop,rerror=stop -device ide-drive,bus=ide.0,unit=0,drive=ide-drive-0,id=ide0 -netdev tap,id=hostnet0,script=/etc/qemu-ifup -device e1000,netdev=hostnet0,id=net0,mac=00:1a:4a:10:84:09,bus=pci.0,addr=0x3 -chardev socket,id=charchannel0,path=/tmp/foo,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.rhevm.vdsm -chardev spicevmc,id=charchannel1,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=2,chardev=charchannel1,id=channel1,name=com.redhat.spice.0 -usb -spice port=5930,disable-ticketing -k en-us -vga qxl -global qxl-vga.vram_size=67108864 -device virtio-balloon-pci,bus=pci.0,id=balloon0

2.Check the guest kernel, xorg-x11-drv-qxl version.
3.Check if the virtio serial and spice-vdagent work well.
Copy/paste some strings from guest to external host. It works.

3.Resize guest screen resolution by click "System" -> "Preferences" -> "Display" on guest desktop.
  
Actual results:
Can not set resolution to larger than 1024x768.
Guest's mouse is captured on the login screen.

Expected results:
Should have more resolution values larger than 1024x768 that's supported by spice+qxl.
Guest's mouse should move external host and guest freely before and after login.

Additional info:
I reinstall a RHEL6.1-64-released guest on the same host, can change the guest resolution successfully.
But after I upgrade RHEL6.1 guest's kernel to a RHEL6.2 version. Sometimes the guest mouse will be captured by desktop.

Comment 2 Gerd Hoffmann 2011-08-30 08:50:11 UTC
Looks like a guest agent issue, pointer grabs shouldn't happen with the guest agent being active.  Hans?

Comment 3 Hans de Goede 2011-09-12 08:00:36 UTC
Ok, so first of all please do *NOT* discuss / file a bug for 2 issues in a single bug!

There are 2 likely completely unrelated issues here:
1) The resolution list is limited to 1024x768 -> this is a xorg-x11-drv-qxl regression, likely caused by recent changing by ssp. Most info in this bug seems to be about that -> changing component to xorg-x11-drv-qxl and assigning to ssp.

2) The mouse is in server mode on the login screen, this is an agent issue and likely the selinux issue we've seen before is not entirely fixed. Qunfang Zhang, can you please edit /etc/sysconfig/selinux in the vm and set "SELINUX=permissive" there and then reboot. After that the mouse should work correctly on the login screen, if that is the case find the selinux-policy bug which was filed for this before and re-open it or file a new bug against selinux-policy.

Comment 4 juzhang 2011-09-13 04:51:03 UTC
Reset qa_ack flag since this issue is changed from qemu-kvm to "xorg-x11-drv-qxl" component.

Comment 5 Qunfang Zhang 2011-09-13 05:52:10 UTC
(In reply to comment #3)
> Ok, so first of all please do *NOT* discuss / file a bug for 2 issues in a
> single bug!
> 
> There are 2 likely completely unrelated issues here:
> 1) The resolution list is limited to 1024x768 -> this is a xorg-x11-drv-qxl
> regression, likely caused by recent changing by ssp. Most info in this bug
> seems to be about that -> changing component to xorg-x11-drv-qxl and assigning
> to ssp.
OK, thanks Hans.

> 
> 2) The mouse is in server mode on the login screen, this is an agent issue and
> likely the selinux issue we've seen before is not entirely fixed. Qunfang
> Zhang, can you please edit /etc/sysconfig/selinux in the vm and set
> "SELINUX=permissive" there and then reboot. After that the mouse should work
> correctly on the login screen, if that is the case find the selinux-policy bug
> which was filed for this before and re-open it or file a new bug against
> selinux-policy.

I found the bug Bug 682416 (SELinux is preventing /usr/bin/spice-vdagent
"write" access on spice-vdagent-sock) that was closed ERRATA. So clone it on
RHEL6.2.
New bug: Bug 737790.

Comment 6 RHEL Product and Program Management 2011-10-07 16:18:34 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 7 Marian Krcmarik 2011-11-29 19:44:07 UTC
- "Guest's mouse is captured on the login screen" was solved in #737790

- "Guest still hang after system reset, the qemu-kvm process consumes 100% host
cpu" was solved in #746950

- "Can not set resolution to larger than 1024x768" I am not able to reproduce with RHEL6.2-20111108.n.0 ( which contains xorg-x11-drv-qxl-0.0.14-10.el6.x86_64.
Could you possibly retest again (make sure qxl driver is in use)?


Note You need to log in before you can comment on or make changes to this bug.