Bug 734374 - boot from SAN will got different mount point with mpath name.
Summary: boot from SAN will got different mount point with mpath name.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.1
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Ales Kozumplik
QA Contact: Gris Ge
URL:
Whiteboard:
Depends On:
Blocks: 743047
TreeView+ depends on / blocked
 
Reported: 2011-08-30 09:02 UTC by Gris Ge
Modified: 2014-09-30 23:40 UTC (History)
2 users (show)

Fixed In Version: anaconda-13.21.139-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 10:41:24 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1565 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2011-12-06 00:39:12 UTC

Description Gris Ge 2011-08-30 09:02:57 UTC
Description of problem:
As comment in https://bugzilla.redhat.com/show_bug.cgi?id=674241#c15

Open a new bug for bindings file creation in anaconda.

Please be advised that when mount point is different from mpath name, multipathd daemon could be stoped without any warning. This will cause OS lose protection from multipath.

Version-Release number of selected component (if applicable):
RHEL6.2-20110823.1

How reproducible:
100%

Steps to Reproduce:
1. Install RHEL 6.2 on a server boot from SAN.
2. Check OS mount point after boot up.
  
Actual results:
OS is mount on /dev/mapper/<WWID>
But multipath only create /dev/mapper/mpath[a-z]+ by default.

Expected results:
mount point should be same as OS do.

Additional info:
If you want to keep use <WWID> when user specify WWID instead of alias, you need to set "user_friendly_names no" in /etc/multipath.conf of OS.

Otherwise, we need to create "/etc/multipath/bindings" both in initramfs and OS.

Comment 1 Ales Kozumplik 2011-08-30 13:38:49 UTC
Hi,

can you please retest with updates=http://akozumpl.fedorapeople.org/bz734374.img ?

Thanks,
Ales

Comment 2 Ales Kozumplik 2011-08-30 13:38:57 UTC
Hi,

can you please retest with updates=http://akozumpl.fedorapeople.org/bz734374.img ?

Thanks,
Ales

Comment 3 Gris Ge 2011-08-31 01:06:53 UTC
Ales,

I don't have physical access to that server, can we have a repo and network-install boot initrd?

Comment 4 Ales Kozumplik 2011-08-31 05:49:43 UTC
(In reply to comment #3)
> Ales,
> 
> I don't have physical access to that server, can we have a repo and
> network-install boot initrd?

You don't need physical access, it is an updates image. This is how you use an updates image: http://fedoraproject.org/wiki/Anaconda/Updates

Comment 5 Gris Ge 2011-09-01 03:21:08 UTC
Alex,

Sorry for the misunderstanding. Add "updates=http://akozumpl.fedorapeople.org/bz734374.img"  into beaker "Kernel Options" fit the needed.

Beaker job:
https://beaker.engineering.redhat.com/jobs/126257

It test 4 senario:
1. ondisk=/dev/disk/by-id/dm-uuid-mpath-WWID
2. ignoredisk --only-use=disk/by-id/scsi-WWID  (typo in beaker whiteboard)
3. ondisk=mpatha
4. ignoredisk --only-use=mpatha

All of them are using mpath[a-z] for mpath name.

So, you create "/etc/multipath/bindings" for all conditions?

Comment 6 Ales Kozumplik 2011-09-05 06:18:50 UTC
(In reply to comment #5)

> All of them are using mpath[a-z] for mpath name.
> 
> So, you create "/etc/multipath/bindings" for all conditions?


No,

only in cases where friendly names are used. But the way to disable friendly names is through UI and is not done simply by using the /by-id/ paths in kickstart. This is the expected behavior.

Ales

Comment 7 Ales Kozumplik 2011-09-06 07:03:34 UTC
Patch posted for review:

https://www.redhat.com/archives/anaconda-devel-list/2011-September/msg00031.html

Comment 8 Gris Ge 2011-09-07 05:14:51 UTC
Any kickstart option I could use to disable friendly names?

Comment 9 Ales Kozumplik 2011-09-07 05:38:01 UTC
(In reply to comment #8)
> Any kickstart option I could use to disable friendly names?

Nope.

Comment 10 Ales Kozumplik 2011-09-07 10:53:25 UTC
Fixed:
445ca8d757c1b388894b46cb22b9646c3a3535ee (rhel6-branch)
ea4a92ce4fd850f77806534153140c3602d2edfe (master)

Comment 13 Gris Ge 2011-09-19 02:41:28 UTC
Ales,

I cannot find any GUI option for disable "friendly names" on repo: RHEL6.2-20110907.1

It might be in "advanced storage" setting page, but that page got skiped when installing on "boot from SAN".

Am I missed anything?

Comment 14 Gris Ge 2011-09-19 05:44:10 UTC
It seems repo RHEL6.2-20110907.1 don't have this patch applied:
https://beaker.engineering.redhat.com/jobs/133061

I will wait for next repo.

Comment 15 Ales Kozumplik 2011-09-19 06:56:21 UTC
(In reply to comment #13)
> Ales,
> 
> I cannot find any GUI option for disable "friendly names" on repo:
> RHEL6.2-20110907.1
> 
> It might be in "advanced storage" setting page, but that page got skiped when
> installing on "boot from SAN".
> 
> Am I missed anything?

The only way to disable friendly names is to enter the "Specialized Storage Devices" page and click "Device Options".

Comment 16 Gris Ge 2011-09-20 06:48:33 UTC
Repo: RHEL6.2-20110919.n.0 have this fix.

Will perform the detailed test after other regression test.

Comment 17 Gris Ge 2011-09-26 07:09:29 UTC
GUI options works as expected.

https://beaker.engineering.redhat.com/jobs/135879
Beaker job confirmed following options works well also:

 1. ondisk=/dev/disk/by-id/dm-uuid-mpath-<WWID>   #without LVM
 2. ignoredisk --only-use=disk/by-id/scsi-<WWID>  #with LVM

Comment 18 errata-xmlrpc 2011-12-06 10:41:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1565.html


Note You need to log in before you can comment on or make changes to this bug.