Bug 73438 - avoid or handle .ICEauthority being owned by root
avoid or handle .ICEauthority being owned by root
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: gnome-session (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
: MoveUpstream, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-04 14:55 EDT by Need Real Name
Modified: 2009-09-29 15:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-12 22:04:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-09-04 14:55:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
When attempting to login after a reboot, the session manager indicated that my
session had lasted less than 10 seconds and then referred me to look at
.xsession-errors

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
The problem turned out to be that the .ICEauthority file was *somehow* owned by
root. After I removed the file from a remote login I was able to login again.



Additional info:

I'm not sure what I did to trigger the .ICEauthority file being owned by root :-(

I had been running koncd, as root (via sudo in a terminal window). I have no
idea if that would cause it. I tried it again and there was no obvious recurrance.

The obvious fix is to make the session scripts check that the .ICEauthority file
is properly configured...
Comment 1 Havoc Pennington 2003-01-12 22:04:52 EST
Upstream as http://bugzilla.gnome.org/show_bug.cgi?id=103302
Comment 2 Landon Kelsey 2009-09-29 15:49:41 EDT
after losing everything to a F10->F11 grub phenomenom ,
I have worked my way back (until today)                
to a working F10                                       
I was just getting back to restoring the original working bash_profile (at the bottom)
and after logging out, I could not log back in even after reboot.                     
I get a message about ...cannot update (or write) to .ICEauthority                    

I created a new user and cannot even log into the new user.
I can however log into root                                
Even a su - to either user will not work                   

[root@eugenemachine ~]# su - oracle
su: warning: cannot change directory to /home/oracle: Permission denied
-bash: /home/oracle/.bash_profile: Permission denied                   
-bash-3.2$ logout   via control d                                      
-bash: /home/oracle/.bash_logout: Permission denied                    
[root@eugenemachine ~]#                                                

[root@eugenemachine oracle]# ls -alF|more       
total 3244                                      
drwxr--r-- 43 oracle oracle      4096 2009-09-29 12:16 ./
drwxr--r--  4 root   root        4096 2009-09-28 16:17 ../
drwxr--r--  3 oracle oinstall    4096 2009-09-22 11:49 .adobe/
drwxr--r--  2 oracle oracle      4096 2009-08-26 00:34 AdobeFlash/
drwxr--r--  2 oracle oinstall    4096 2009-09-28 15:03 bash1/     
drwxr--r--  2 oracle oracle      4096 2009-09-28 17:57 bash2/     
-rwxr--r--  1 oracle oinstall   14440 2009-09-28 15:35 .bash_history*
-rwxr--r--  1 oracle oinstall      18 2009-09-28 20:45 .bash_logout* 
-rwxr--r--  1 oracle oinstall     176 2009-09-28 20:45 .bash_profile*
-rwxr--r--  1 oracle oinstall     124 2009-09-28 20:45 .bashrc*      
drwxr--r--  7 oracle oracle      4096 2009-09-28 14:51 .beagle/      

some post recommended I delete .ICEauthority and reboot but that didn't work
until I changed ownership/permissions. There after .ICEauthority was created
when I logged in.                                                           
I did save .ICEauthority just in case                                       

[root@eugenemachine oracle]# ls -alF /home
total 24                                  
drwxr--r--  4 root   root   4096 2009-09-28 16:17 ./
drwxr-xr-x 24 root   root   4096 2009-09-29 08:25 ../
drwx------  4 eugene eugene 4096 2009-09-28 16:17 eugene/
drwxr--r-- 43 oracle oracle 4096 2009-09-29 11:19 oracle/
[root@eugenemachine oracle]#                             

[root@eugenemachine oracle]# pwd
/home/oracle                    
[root@eugenemachine oracle]# ls -alF .ICEauthority
-rwxrwxrwx 1 oracle oinstall 930 2009-09-28 18:15 .ICEauthority*
[root@eugenemachine oracle]#                                    

_______________________________________________________________________
# .bash_profile                                                        
# for Qt 4                                                             

# Get the aliases and functions
if [ -f ~/.bashrc ]; then      
        . ~/.bashrc            
fi                             

# alias ls -alF='ls -alF --color'
# alias h=history                
# User specific environment and startup programs

HIST=1024
hist=1024
savehist=1024
SAVEHIST=1024

# mount --move /mnt/usbdrive /home/eugene/usb
QTDIR=/usr/lib/qt4                           
# QTDIR=/usr/lib/qt-3.3                      
CPLUS_INCLUDE_PATH=$QTDIR/include            
BASH_ENV=$HOME/.bashrc                       
USERNAME=""                                  

LD_LIBRARY_PATH=/usr/lib
LIBRARY_PATH=$LD_LIBRARY_PATH
QTLIB=$LD_LIBRARY_PATH       
# LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/Trolltech/Qt-4.2.2/lib
# LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/lib:/usr/lib                    
# LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib                   
PS1="\h (\u) \w [\!]>"                                              

PATH=$QTDIR/bin:$QTDIR:$QTLIB:$PATH:$HOME/bin:.
export PS1                                     
export USERNAME                                
export LD_LIBRARY_PATH                         
export PATH                                    
export QTDIR                                   
export LIBRARY_PATH                            
export CPLUS_INCLUDE_PATH                      
export BASH_ENV                                
export HIST                                    
export hist                                    
export savehist                                
export SAVEHIST                                
# unset USERNAME                               

# Oracle Settings
TMP=/tmp; export TMP
TMPDIR=$TMP; export TMPDIR

ORACLE_HOSTNAME=localhost.localdomain; export ORACLE_HOSTNAME
ORACLE_BASE=/u01/app/oracle; export ORACLE_BASE              
ORACLE_HOME=$ORACLE_BASE/product/11.1.0/db_1; export ORACLE_HOME
ORACLE_SID=EUGENEGDNSID; export ORACLE_SID                      
TNS_ADMIN=/u01/app/oracle/product/11.1.0/db_1/network/admin export TNS_ADMIN

ORACLE_TERM=xterm; export ORACLE_TERM
PATH=/usr/sbin:$PATH; export PATH    
# PATH=$ORACLE_HOME/bin:$PATH; export PATH
PATH=$PATH:$HOME/bin:$ORACLE_HOME/bin     

LD_LIBRARY_PATH=$ORACLE_HOME/lib:/lib:/usr/lib; export LD_LIBRARY_PATH
CLASSPATH=$ORACLE_HOME/JRE:$ORACLE_HOME/jlib:$ORACLE_HOME/rdbms/jlib; export CLASSPATH

if [ $USER = "oracle" ]; then
  if [ $SHELL = "/bin/ksh" ]; then
    ulimit -p 16384               
    ulimit -n 65536               
  else                            
    ulimit -u 16384 -n 65536      
  fi                              
fi                                

LIBXCB_ALLOW_SLOPPY_LOCK=true; export LIBXCB_ALLOW_SLOPPY_LOCK

___________________________________________________________
Using chmod 755 and 777, I made the thing work.
I can login either user now.
current state:

[root@eugenemachine oracle]# lsa /home
total 24
drwxrwxrwx  4 root   root   4096 2009-09-28 16:17 ./
drwxr-xr-x 24 root   root   4096 2009-09-29 13:04 ../
drwxrwxrwx  4 eugene eugene 4096 2009-09-28 16:17 eugene/
drwxrwxrwx 49 oracle oracle 4096 2009-09-29 13:17 oracle/
[root@eugenemachine oracle]# lsa |more
ls: cannot access .gvfs: Permission denied
total 3276
drwxrwxrwx 49 oracle oracle      4096 2009-09-29 13:17 ./
drwxrwxrwx  4 root   root        4096 2009-09-28 16:17 ../
drwxr--r--  3 oracle oinstall    4096 2009-09-22 11:49 .adobe/
drwxr--r--  2 oracle oracle      4096 2009-08-26 00:34 AdobeFlash/
drwxr--r--  2 oracle oinstall    4096 2009-09-28 15:03 bash1/
drwxr--r--  2 oracle oracle      4096 2009-09-28 17:57 bash2/
-rwxr-xr-x  1 oracle oinstall   14402 2009-09-29 13:09 .bash_history*
-rwxr-xr-x  1 oracle oinstall      18 2009-09-29 13:08 .bash_logout*
-rwxr-xr-x  1 oracle oinstall    1828 2009-09-29 13:08 .bash_profile*
-rwxr-xr-x  1 oracle oinstall     170 2009-09-29 13:08 .bashrc*

new problem: what is ,gvfs?  I cannot change the permissions or ownership
-rw-r--r--  1 oracle oinstall      35 2009-09-29 13:10 .gpg-agent-info
drwxr--r--  2 oracle oracle      4096 2009-08-24 14:25 .gstreamer-0.10/
-rw-r--r--  1 oracle oinstall     141 2009-09-29 13:05 .gtk-bookmarks
d?????????  ? ?      ?              ?                ? .gvfs/
drwxr--r--  3 oracle oinstall    4096 2009-09-28 13:54 html/
drwxr--r--  3 oracle oinstall    4096 2008-12-20 19:42 htmlold/


now I have :

drwxr--r-- 3 oracle oracle 4096 2009-08-24 19:35 .gnupg/
-rw-r--r-- 1 oracle oinstall 35 2009-09-29 13:10 .gpg-agent-info
drwxr--r-- 2 oracle oracle 4096 2009-08-24 14:25 .gstreamer-0.10/
-rw-r--r-- 1 oracle oinstall 141 2009-09-29 13:05 .gtk-bookmarks
d????????? ? ? ? ? ? .gvfs/

what is .gvfs???

I copied the directory (empty) from root and changed permissions and owner.

Everything seems to be working OK!

Note You need to log in before you can comment on or make changes to this bug.