Bug 734585 - [RV515] XFCE session crashes
Summary: [RV515] XFCE session crashes
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 15
Hardware: i686
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: [cat:crash]
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-30 20:00 UTC by Konstantin Svist
Modified: 2018-04-11 13:21 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-28 19:31:14 UTC


Attachments (Terms of Use)
dmesg (124.31 KB, text/plain)
2011-09-03 03:34 UTC, Konstantin Svist
no flags Details
/var/log/messages (191.96 KB, text/plain)
2011-09-03 03:37 UTC, Konstantin Svist
no flags Details
/var/log/Xorg.0.log (85.81 KB, text/plain)
2011-09-03 03:38 UTC, Konstantin Svist
no flags Details
/var/log/Xorg.0.log.old (87.39 KB, text/plain)
2011-09-03 03:39 UTC, Konstantin Svist
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 728720 None None None Never

Internal Links: 728720

Description Konstantin Svist 2011-08-30 20:00:19 UTC
Description of problem:
XFCE session keeps crashing at random times. Most often this happens when I press Logout in the Applications menu - instead of showing the logout dialog (Shutdown/reboot/etc.), session disappears and gdm screen appears. ABRT does not show up asking to send data to bugzilla, but the following is written to /var/log/messages:

Aug 30 12:48:43 mireille abrt[2520]: saved core dump of pid 672 (/usr/bin/Xorg) to /var/spool/abrt/ccpp-2011-08-30-12:48:43-672.new/coredump (2433024 bytes)
Aug 30 12:48:43 mireille abrtd: Directory 'ccpp-2011-08-30-12:48:43-672' creation detected
[...]
Aug 30 12:48:45 mireille abrtd: Can't open file '/var/spool/abrt/pyhook-1293051654-7465/uuid': No such file or directory
Aug 30 12:48:45 mireille abrtd: Can't open file '/var/spool/abrt/kerneloops-1305228865-1427-1/uuid': No such file or directory
Aug 30 12:48:45 mireille abrtd: Can't open file '/var/spool/abrt/kerneloops-1305573542-1429-1/uuid': No such file or directory
Aug 30 12:48:45 mireille abrtd: Can't open file '/var/spool/abrt/pyhook-1310580279-9248/uuid': No such file or directory
Aug 30 12:48:45 mireille abrtd: Can't open file '/var/spool/abrt/ccpp-1301102183-2555/uuid': No such file or directory
Aug 30 12:48:45 mireille abrtd: New dump directory /var/spool/abrt/ccpp-2011-08-30-12:48:43-672, processing



Version-Release number of selected component (if applicable):


How reproducible:
Random, can't reproduce reliably. At logout crashes every other day or two.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Kevin Fenzi 2011-08-30 20:12:53 UTC
This looks like a X server crash... 

Look in /var/log/Xorg.0.log.old and see if you see a crash? 
See: http://fedoraproject.org/wiki/Xorg/Debugging

Comment 2 Konstantin Svist 2011-08-30 20:52:45 UTC
/var/log/Xorg.0.log.old doesn't mention anything about a crash; last few lines are

[    13.943] (II) RADEON(0): Modeline "1600x1200"x0.0  162.00  1600 1664 1856 2160  1200 1201 1204 1250 +hsync +vsync (75.0 kHz)
[    13.943] (II) RADEON(0): Modeline "1680x1050"x0.0  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync (65.3 kHz)


/var/log/Xorg.0.log starts from right after the crash, according to the timestamp

Comment 3 Kevin Fenzi 2011-08-30 21:38:54 UTC
Anything in ~/.xsession-errors after a crash?

Comment 4 Konstantin Svist 2011-08-30 22:04:26 UTC
No, it only has current session's data:

/usr/bin/startxfce4: X server already running on display :0
xrdb:  "Xft.hinting" on line 9 overrides entry on line 6
xrdb:  "Xft.hintstyle" on line 11 overrides entry on line 7
ssh-agent is already running; starting gpg-agent without ssh support
xfdesktop[2797]: starting up


I've checked that 2797 is currently running pid of xfdesktop. Looks like ~/.xsession-errors gets blanked after crash

Comment 5 Matěj Cepl 2011-09-01 09:15:07 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log*; check with grep Backtrace /var/log/Xorg* which logs might be the most interesting ones, send us at least Xorg.0.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 6 Konstantin Svist 2011-09-03 03:34:17 UTC
Created attachment 521310 [details]
dmesg

/etc/X11/xorg.conf.d/00-system-setup-keyboard.conf:
Section "InputClass"
	Identifier	"system-setup-keyboard"
	MatchIsKeyboard	"on"
	Option		"XkbModel"	"pc105+inet"
	Option		"XkbLayout"	"us"
	Option		"XkbOptions"	"terminate:ctrl_alt_bksp,"
EndSection

Comment 7 Konstantin Svist 2011-09-03 03:37:24 UTC
Created attachment 521311 [details]
/var/log/messages

Comment 8 Konstantin Svist 2011-09-03 03:38:49 UTC
Created attachment 521312 [details]
/var/log/Xorg.0.log

Comment 9 Konstantin Svist 2011-09-03 03:39:11 UTC
Created attachment 521313 [details]
/var/log/Xorg.0.log.old

Comment 10 Matěj Cepl 2011-09-04 00:26:30 UTC
Backtrace:
[ 29929.774] 0: /usr/bin/Xorg (xorg_backtrace+0x3c) [0x80a404c]
[ 29929.774] 1: /usr/bin/Xorg (0x8047000+0x61456) [0x80a8456]
[ 29929.774] 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xa3140c]
[ 29929.774] 3: /lib/libc.so.6 (0x4dcd9000+0x7a7d6) [0x4dd537d6]
[ 29929.774] Segmentation fault at address 0xb0bf2000
[ 29929.774] 
Fatal server error:
[ 29929.774] Caught signal 11 (Segmentation fault). Server aborting

Comment 12 Mattia Verga 2011-09-05 15:13:30 UTC
It randomly happens to me also, but I use KDE with Catalyst drivers on kernel 2.6.40.3-0.fc15.x86_64.
The crash happens when I launch Firefox, but not every time.

Backtrace:
[   247.175] 0: /usr/bin/X (xorg_backtrace+0x2f) [0x45e7ff]
[   247.175] 1: /usr/bin/X (0x400000+0x62e86) [0x462e86]
[   247.175] 2: /lib64/libpthread.so.0 (0x3ca1200000+0xeef0) [0x3ca120eef0]
[   247.175] 3: /usr/lib64/dri/fglrx_dri.so (0x7fe49d1c9000+0xc456e8) [0x7fe49de0e6e8]
[   247.175] 4: /usr/lib64/dri/fglrx_dri.so (0x7fe49d1c9000+0xc46469) [0x7fe49de0f469]
[   247.175] 5: /usr/lib64/dri/fglrx_dri.so (0x7fe49d1c9000+0xc467eb) [0x7fe49de0f7eb]
[   247.175] 6: /usr/lib64/dri/fglrx_dri.so (0x7fe49d1c9000+0xa310b1) [0x7fe49dbfa0b1]
[   247.175] 7: /usr/lib64/dri/fglrx_dri.so (0x7fe49d1c9000+0x231dde) [0x7fe49d3fadde]
[   247.175] 8: /usr/lib64/dri/fglrx_dri.so (0x7fe49d1c9000+0xdccdc3) [0x7fe49df95dc3]
[   247.175] 9: /usr/lib64/dri/fglrx_dri.so (0x7fe49d1c9000+0xdcb7bd) [0x7fe49df947bd]
[   247.175] 10: /usr/lib64/dri/fglrx_dri.so (0x7fe49d1c9000+0xde8edf) [0x7fe49dfb1edf]
[   247.175] 11: /usr/lib64/dri/fglrx_dri.so (0x7fe49d1c9000+0x18d9b96) [0x7fe49eaa2b96]
[   247.175] 12: /usr/lib64/xorg/modules/extensions/catalyst/libglx.so (0x7fe4a3320000+0x1b753) [0x7fe4a333b753]
[   247.175] 13: /usr/lib64/xorg/modules/extensions/catalyst/libglx.so (0x7fe4a3320000+0x1e52d) [0x7fe4a333e52d]
[   247.175] 14: /usr/lib64/xorg/modules/extensions/catalyst/libglx.so (0x7fe4a3320000+0x1e569) [0x7fe4a333e569]
[   247.175] 15: /usr/bin/X (FreeResourceByType+0x11d) [0x44c25d]
[   247.175] 16: /usr/lib64/xorg/modules/extensions/catalyst/libglx.so (0x7fe4a3320000+0x158b6) [0x7fe4a33358b6]
[   247.175] 17: /usr/lib64/xorg/modules/extensions/catalyst/libglx.so (0x7fe4a3320000+0x1e757) [0x7fe4a333e757]
[   247.176] 18: /usr/bin/X (0x400000+0x2edb1) [0x42edb1]
[   247.176] 19: /usr/bin/X (0x400000+0x22e1a) [0x422e1a]
[   247.176] 20: /lib64/libc.so.6 (__libc_start_main+0xed) [0x3ca0a2139d]
[   247.176] 21: /usr/bin/X (0x400000+0x23101) [0x423101]
[   247.176] Segmentation fault at address (nil)
[   247.176] 
Fatal server error:
[   247.176] Caught signal 11 (Segmentation fault). Server aborting

Comment 13 Matěj Cepl 2011-09-05 16:08:11 UTC
(In reply to comment #12)
> It randomly happens to me also, but I use KDE with Catalyst drivers on kernel
> 2.6.40.3-0.fc15.x86_64.

We don't support Catalyst driver.

Comment 14 Jérôme Glisse 2011-10-28 19:31:14 UTC
No our bug, fglrx


Note You need to log in before you can comment on or make changes to this bug.