Bug 734619 - SME Review Getting Started Guide, Chapter 5
Summary: SME Review Getting Started Guide, Chapter 5
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Virtualization_Getting_Started_Guide
Version: 6.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jacquelynn East
QA Contact: ecs-bugs
URL: http://documentation-stage.bne.redhat...
Whiteboard:
: 734667 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-30 22:32 UTC by Don Dutile
Modified: 2015-07-26 22:09 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-31 01:07:22 UTC


Attachments (Terms of Use)

Description Don Dutile 2011-08-30 22:32:30 UTC
Description of problem:
SME review of chapter 5 found these errors and/or needed corrections:
(1) Section 5.1 virsh
    (a) heavy use of 'domains', which is ok, but the doc previously used
        'guests' or 'guest virtual machines' or 'guest VMs'.

(2) Section 5.2 virt-manager
    (a) like other tools, should list that it's package is virt-manager,
        so customers don't infer its in libvirt-client or other pkg.

(3) Section 5.3 virt-install
    (a) spice is also support for graphics, so the following:
        "SDL graphics, or a VNC client/server pair."
        should be replaced by:
        "SDL, SPICE, or VNC client/server pair graphics."

(4) Section 5.5 Other useful tools
     (a) virt-filesystems
         -- it is part of libguestfs-tools-c package, 
             not libguestfs-tools package.
     (b) virt-ls
         -- ditto (a)
     (c) virt-p2v
         -- *remove*; it will not make rhel6.2
     (d) virt-resize
         -- what does "in-place" mean in the description ? -- ask rjones?


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 3 Jacquelynn East 2011-08-31 06:18:51 UTC
*** Bug 734667 has been marked as a duplicate of this bug. ***

Comment 6 Richard W.M. Jones 2011-08-31 07:51:08 UTC
(In reply to comment #0)

> (4) Section 5.5 Other useful tools
>      (a) virt-filesystems
>          -- it is part of libguestfs-tools-c package, 
>              not libguestfs-tools package.
>      (b) virt-ls
>          -- ditto (a)

Don is strictly correct.  However it is better if people
"yum install libguestfs-tools" (not libguestfs-tools-c).

libguestfs-tools requires libguestfs-tools-c.  The reason
we have the package split is to allow RHEV-H to just
include libguestfs-tools-c (ie. the tools that are written
in C and don't require Perl).  libguestfs-tools-c is kind
of an internal package.

I would just leave the documentation as it is.

>      (d) virt-resize
>          -- what does "in-place" mean in the description ? -- ask rjones?

Change: "It cannot resize disk images in-place."
to: "It works by copying the guest image and leaving the original disk image untouched."

Comment 7 Don Dutile 2011-08-31 19:46:05 UTC
If libguestfs-tools requires libguestfs-tools-c, then all the other references
in that section to libguestfs-tools-c should be changed to libguestfs-tools.

so the above is the needed change/bz in the doc.

Comment 8 Richard W.M. Jones 2011-08-31 20:24:05 UTC
Yup, I didn't notice those.

It's probably best if all references to libguestfs-tools-c
are changed to libguestfs-tools.

libguestfs-tools requires libguestfs-tools-c at installation
time so the effect is that customers will get all of the tools
installed at once.


Note You need to log in before you can comment on or make changes to this bug.