Bug 734621 - internal compiler error: Segmentation fault while building wxPython
Summary: internal compiler error: Segmentation fault while building wxPython
Keywords:
Status: CLOSED DUPLICATE of bug 735304
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gcc
Version: 5.7
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: rc
: ---
Assignee: Jakub Jelinek
QA Contact: qe-baseos-tools
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-30 23:09 UTC by unixops
Modified: 2011-10-21 12:25 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-21 12:25:58 UTC


Attachments (Terms of Use)
Preprocessed source (1.80 MB, application/octet-stream)
2011-08-30 23:09 UTC, unixops
no flags Details

Description unixops 2011-08-30 23:09:28 UTC
Created attachment 520706 [details]
Preprocessed source

Description of problem:
wxPython 2.8.12.0 fails to build on RHEL 5.7 using standard build tools.

Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
1. download and extract source from http://sourceforge.net/projects/wxpython/files/wxPython/2.8.12.0/wxPython-src-2.8.12.0.tar.bz2/download

2. configure --prefix=/usr/local/wx --with-gtk --with-gnomeprint --with-opengl --enable-optimize --enable-debug_gdb --enable-debug_flag --enable-rpath=/usr/local/wx/lib --enable-geometry --enable-graphics_ctx --enable-sound --with-sdl --enable-mediactrl --enable-display --enable-unicode --with-libjpeg=builtin --with-libpng=builtin --with-libtiff=builtin --with-zlib=builtin
3. make
  
Actual results:
/tmp/wxbuild28120/bk-deps g++ -c -o coredll_event.o -I./.pch/wxprec_coredll -D__WXGTK__     -DWXBUILDING -I../wxPython-src-2.8.12.0/src/tiff -I../wxPython-src-2.8.12.0/src/jpeg -I../wxPython-src-2.8.12.0/src/png -I../wxPython-src-2.8.12.0/src/zlib  -I../wxPython-src-2.8.12.0/src/regex  -DWXUSINGDLL -DWXMAKINGDLL_CORE -DwxUSE_BASE=0 -fPIC -DPIC -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D__WXDEBUG__ -I/tmp/wxbuild28120/lib/wx/include/gtk2-unicode-debug-2.8 -I../wxPython-src-2.8.12.0/include -pthread -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/libpng12 -DWX_PRECOMP -pthread -Wall -Wundef -Wno-ctor-dtor-privacy -ggdb -O2 -fno-strict-aliasing -I/usr/include/libgnomeprintui-2.2 -I/usr/include/libgnomeprint-2.2 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/libart-2.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libxml2 -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/libpng12 -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT ../wxPython-src-2.8.12.0/src/common/event.cpp

../wxPython-src-2.8.12.0/include/wx/geometry.h: In member function ‘virtual wxPoint2DInt wxTransform2D::Transform(const wxPoint2DInt&) const’:

../wxPython-src-2.8.12.0/include/wx/geometry.h:797: internal compiler error: Segmentation fault


Expected results:
output file coredll_event.o 

Additional info: This system is up to date as of Aug 30 2011, also this software built successfully June 28 2011.

Comment 1 Jakub Jelinek 2011-10-21 12:25:58 UTC
Most likely dup of #735304.  Can't reproduce on the preprocessed source and from
-I./.pch/wxprec_coredll I guess you are using PCH.

*** This bug has been marked as a duplicate of bug 735304 ***


Note You need to log in before you can comment on or make changes to this bug.