Bug 734639 - SME Review Host Config n Guest Installation Guide ch 4
Summary: SME Review Host Config n Guest Installation Guide ch 4
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Deadline: 2011-09-15
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Virtualization_Host_Configuration_and_Guest_Installation_Gui
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Scott Radvan
QA Contact: ecs-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-31 03:06 UTC by Don Dutile
Modified: 2015-04-07 03:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-04 00:52:14 UTC


Attachments (Terms of Use)

Description Don Dutile 2011-08-31 03:06:06 UTC
Description of problem:
SME review of chapter 4 found these errors and/or needed corrections:

 4.1 KVM Restrictions
    (a) under Memory overcommit
        i) mixing a comparison of raw size to ratio:
           "... make sure that the swap size is greater than or equal 
            to the size of the overcommit ratio. "
    (b)  under CPU overcommit:
        i) is 10 vCPUs per physical processor core still a recommended limit?
       ii) replace 'problems' with 'run time delays'
    (c) under Para-virtualized devices
        change "a maximum of 221 PCI devices" 
            to "a static definition of 221 PCI devices"
        (note: dynamic vs static definition will be better spelled out 
               in to-be-created 12.4)
    (d) SR-IOV restrictions
        i) suggest moving to SR-IOV section
       ii) tested devices fairly dynamic; for example, 
            a new Intel NIC w/SRIOV is being
            tested.... (x540 -- ixgbevf derivative).
          -> is there a hw cert web link we could put here ???
    (e) PCI device assignment restrictions
        i) *strongly* suggest moving to 12.4 
            -- in fact, that's just part of what I want to put in 12.4
       ii) also missing: in rhel6.2, it also requires interrupt-remapping now;
           if a platform doesn't have interrupt remapping support,
           the kvm check can be circumvented by exec-ing the following:
            echo 1 > /sys/module/kvm/parameters/allow_unsafe_assigned_interrupts


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 3 Dor Laor 2011-09-15 15:05:33 UTC
Instead of the current state:
"CPU overcommit
 It is not recommended to have more than 10 virtual CPUs per physical 
 processor core. Any number of
 overcommitted virtual CPUs above the number of physical processor cores 
 may cause run time delays with certain virtualized guests.
 Refer to the Red Hat Enterprise Linux Virtualization Administration 
 Guide for tips and recommendations on overcommitting CPUs."

I think we should generalize it and say that:
It is not recommended to have more than 10 virtual CPUs per physical 
processor core. Customers are encouraged to use a capacity planning tool in order to determine the cpu over commit ration. It is hard to estimate what's the actual ratio would be since it is highly dependent on the workload - A VM may consume 100% cpu on one use case and multiple VMs would be completely idle on others.

In addition to that, note that we do not support running more #vcpu belonging to a single VMs than the number of overall physical cores. Hyperthread can be considered cores but expect them not to perform as regular cores. It may vary between one scenario to the next


Note You need to log in before you can comment on or make changes to this bug.