Bug 734680 - Frequently crashes with "stream_mjpeg_data: assertion `j == st->mjpeg_cinfo.rec_outbuf_height' failed"
Frequently crashes with "stream_mjpeg_data: assertion `j == st->mjpeg_cinfo.r...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: spice-gtk (Show other bugs)
16
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Marc-Andre Lureau
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-31 03:01 EDT by Adam Williamson
Modified: 2011-09-09 13:09 EDT (History)
4 users (show)

See Also:
Fixed In Version: spice-gtk-0.7.39-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-09 13:09:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2011-08-31 03:01:21 EDT
In F16, virt-manager seems to crash a lot when viewing a guest - seen this with F15, F16 and Win7 guests, so what's going on in the guest doesn't seem to be terribly important. virt-manager just disappears, abrt doesn't catch the crash, and nothing shows on the console. But I just tried running spice-gtk directly, and it quickly crashed with this console message:

(spicy:8684): GSpice-CRITICAL **: stream_mjpeg_data: assertion `j == st->mjpeg_cinfo.rec_outbuf_height' failed

(spicy:8684): GSpice-CRITICAL **: stream_mjpeg_data: assertion `j == st->mjpeg_cinfo.rec_outbuf_height' failed
Improper call to JPEG library in state 205

so I suspect that's the problem.

Seems to be sufficient just to run any VM (possibly with a native qxl driver?) for a few minutes to reproduce.

spicec seems to be immune.
Comment 1 Marc-Andre Lureau 2011-08-31 07:03:08 EDT
This bug is fixed in v0.7-5-gb306504, by Christophe. We need to make a new release.

Fortunately, Hans has planned to do it shortly.
Comment 2 Adam Williamson 2011-08-31 17:32:50 EDT
I did a personal build with all four patches from Christophe related to mjpeg (on 07-29), but I'm still hitting this, actually now on a VM which is a Win7 install which is *not* yet using a native qxl driver:

(spicy:10544): GSpice-CRITICAL **: stream_mjpeg_data: assertion `j == st->mjpeg_cinfo.rec_outbuf_height' failed
Improper call to JPEG library in state 205

maybe it's not totally fixed yet?
Comment 3 Christophe Fergeau 2011-09-01 01:24:28 EDT
Hey Adam, before trying to reproduce this bug, I'd need a few more details.

First of all, are you 100% positive you were running code with these fixes applied? If you rebuilt a spice-gtk package, the fixed code will end up in the spice-glib subpackage, maybe you didn't upgrade this one?

Then can you clarify whether you are using qxl or not, or if qxl does not matter? In the initial description, you seem to be using a guest with qxl to reproduce (?), but then in comment #2 you say you're not using a qxl driver (which is surprising, iirc the mjpeg compression code only gets triggered when using qxl).

And lastly, what versions of qemu and spice-server are you using?

Thanks!
Comment 4 Adam Williamson 2011-09-02 17:25:22 EDT
christophe: ah, indeed I didn't update spice-glib. will do that and re-test. i'm definitely hitting this in a Win7 VM without the native qxl driver installed, though, so the VM has the qxl 'adapter' but the guest OS is using a vesa-ish driver (whatever Win7's compatibility driver is).
Comment 5 Adam Williamson 2011-09-02 17:35:01 EDT
looking good now I updated spice-glib as well, the usual reproducer (log into or out of the vm) seems not to crash any more.
Comment 6 Fedora Update System 2011-09-03 03:38:37 EDT
spice-gtk-0.7.39-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/spice-gtk-0.7.39-1.fc16
Comment 7 Fedora Update System 2011-09-06 14:07:44 EDT
Package spice-gtk-0.7.39-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing spice-gtk-0.7.39-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/spice-gtk-0.7.39-1.fc16
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2011-09-09 13:09:36 EDT
spice-gtk-0.7.39-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.