Bug 734693 - Install Graphics as Spice is not taken effect in Preferences setting
Summary: Install Graphics as Spice is not taken effect in Preferences setting
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager
Version: 6.2
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Cole Robinson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 748554
TreeView+ depends on / blocked
 
Reported: 2011-08-31 07:53 UTC by min zhan
Modified: 2011-12-06 16:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Clone Of:
Environment:
Last Closed: 2011-12-06 16:15:36 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1642 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2011-12-06 00:50:37 UTC

Description min zhan 2011-08-31 07:53:45 UTC
Description of problem:
Launch virt-manager, Click Edit -> Preferences, Choose SPICE as Install Graphics, then close. New a guest in localhost connection, found its graphics is still VNC.

Version-Release number of selected component (if applicable):
# uname -r
2.6.32-191.el6.x86_64
qemu-kvm-0.12.1.2-2.184.el6.x86_64
libvirt-0.9.4-6.el6.x86_64
virt-manager-0.9.0-6.el6.x86_64
python-virtinst-0.600.0-3.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. As description

  
Actual results:
As above

Expected results:
New guest graphics should be SPICE.

Additional info:

Comment 2 Cole Robinson 2011-09-27 15:49:05 UTC
Since spice is supposed to be the default graphics device for new guests, we want this fixed for 6.2. Setting blocker?

Comment 3 Cole Robinson 2011-10-13 21:49:18 UTC
Fixed in virt-manager-0.9.0-7.el6

Comment 6 Daisy Wu 2011-10-17 03:43:45 UTC
The bug can reproduce on version:
virt-manager-0.9.0-6.el6

Verified on version:
virt-manager-0.9.0-7.el6

Environment:
kernel-2.6.32-206.el6.x86_64
libvirt-0.9.4-17.el6
python-virtinst-0.600.0-3.el6
qemu-kvm-0.12.1.2-2.195.el6.x86_64

Detail Steps:
1.Launch virt-manager
2.Click Edit -> Preferences, Choose SPICE as Install Graphics, then close.
3.New a guest in localhost connection, found its graphics is SPICE.
#virsh dumpxml rhel6.2
.....
<graphics type='spice' port='5900' tlsPort='-1' autoport='yes'/>
.....

so change the status to verified.

Comment 7 Cole Robinson 2011-11-07 16:43:09 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description necessary

Comment 8 errata-xmlrpc 2011-12-06 16:15:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1642.html


Note You need to log in before you can comment on or make changes to this bug.