Bug 734696 - Resource leak revealed by Coverity
Summary: Resource leak revealed by Coverity
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Zdenek Kabelac
QA Contact: Corey Marthaler
URL:
Whiteboard:
Depends On:
Blocks: 743047
TreeView+ depends on / blocked
 
Reported: 2011-08-31 08:00 UTC by Pavel Raiskup
Modified: 2011-12-06 17:02 UTC (History)
9 users (show)

Fixed In Version: lvm2-2.02.87-2.el6
Doc Type: Bug Fix
Doc Text:
Do not document.
Clone Of:
Environment:
Last Closed: 2011-12-06 17:02:57 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1522 normal SHIPPED_LIVE lvm2 bug fix and enhancement update 2011-12-06 00:50:10 UTC

Description Pavel Raiskup 2011-08-31 08:00:35 UTC
This problem was newly found in RHEL 6.2 by coverity difference scan on RHEL packages 6.1 → 6.2. Version of lvm2 during the test was 2.02.87.

a) daemons/dmeventd/dmeventd.c:749: 
   Calling allocation function "dm_task_create".

b) daemons/dmeventd/dmeventd.c:755:
   leaked_storage: Variable "dmt" going out of scope leaks the storage it
   points to.

Comment 2 Zdenek Kabelac 2011-08-31 08:25:25 UTC
Fixed by upstream commit:

https://www.redhat.com/archives/lvm-devel/2011-August/msg00118.html

Comment 3 Corey Marthaler 2011-08-31 15:18:07 UTC
Adding QA ack for 6.2.

Based on comment #0, there's really no way to test this issue. This bug will mostly be marked verified (SanityOnly) once final 6.2 regression testing has been completed.

Comment 6 Corey Marthaler 2011-09-26 22:10:31 UTC
Marking verify based on comment #5.

Comment 7 Peter Rajnoha 2011-10-26 12:50:00 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Do not document.

Comment 9 errata-xmlrpc 2011-12-06 17:02:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1522.html


Note You need to log in before you can comment on or make changes to this bug.