Bug 734721 - Coverity defects newly introduced in RHEL6.2 (netcf)
Summary: Coverity defects newly introduced in RHEL6.2 (netcf)
Keywords:
Status: CLOSED DUPLICATE of bug 728184
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: netcf
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Laine Stump
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-31 09:36 UTC by Pavel Raiskup
Modified: 2011-09-06 17:56 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-06 17:56:51 UTC


Attachments (Terms of Use)

Description Pavel Raiskup 2011-08-31 09:36:56 UTC
1) Use of uninitialized value 'nphys'

   => src/dutil_linux.c

   a) line 1022: declaring nphys
   b) line 1028: allocation of "bridge_node" failed
   c) line 1029: goto err;
   d) line 1055: for (ii = 0, ii < nphys, ..)

2) Use of uninitialized value "phys_names"

   => src/dutil_linux.c:1021

   the same situation as above. When xml_node fails, program jumps
   to line 1054 and tries to free uninitialized value.

These problems were newly found in RHEL 6.2 by coverity difference scan on RHEL packages 6.1 → 6.2.

Comment 2 Laine Stump 2011-09-06 17:56:51 UTC

*** This bug has been marked as a duplicate of bug 728184 ***


Note You need to log in before you can comment on or make changes to this bug.