Bug 73474 - update to version XFree86-4.2.0-71 is lethal (X won't start)
Summary: update to version XFree86-4.2.0-71 is lethal (X won't start)
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: null
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-09-05 04:37 UTC by Need Real Name
Modified: 2007-04-18 16:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-05 07:55:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-09-05 04:37:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020826

Description of problem:
after applying the latest XFree rpms I get the following error:

X: relocation error: X: symbol __ctype_b_loc, version GLIBC_2.3 not defined in
file libc.so.6 with link time reference



Version-Release number of selected component (if applicable):
XFree86-4.2.0-71


How reproducible:
Always

Steps to Reproduce:
1.Run up2date on Redhat-null-beta
2.Log out of X
3.Gdm fails to restart, try console login, startx, see error message
	

Actual Results:  X fails to start, error message looks like dynamic link error
with libc.so

Expected Results:  X should restart after logout and Gdm greeter screen should
appear.

Additional info:

At least one other person complained about this one on the limbo mailing list.

Comment 1 Reid Rivenburgh 2002-09-05 06:43:46 UTC
Falling back to XFree86-libs-4.2.0-67.6.i386.rpm fixed the problem for me. 
xemacs and other applications (like up2date) wouldn't start with
XFree86-libs-4.2.0-71.  Something a little fishy in that version....


Comment 2 Barry K. Nathan 2002-09-05 07:39:38 UTC
The actual fix (as seen on limbo-list) is glibc 2.2.93-2 (now on up2date).

Comment 3 Mike A. Harris 2002-09-05 07:54:59 UTC
This was actually as barryn says a glibc update requirement issue.

If you upgrade glibc to the 2.2.93-2 version does X work properly?

Comment 4 Mike A. Harris 2002-09-05 11:53:42 UTC
Confirmed as glibc update.  Closing as fixed in RAWHIDE.


Note You need to log in before you can comment on or make changes to this bug.