Bug 734788 - Dependent enumeration fields not showing for DSL sentences
Summary: Dependent enumeration fields not showing for DSL sentences
Keywords:
Status: CLOSED DUPLICATE of bug 724529
Alias: None
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: BRM (Guvnor)
Version: BRMS 5.2.0-ER1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Tihomir Surdilovic
QA Contact: Zuzana Krejčová
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-31 13:11 UTC by Zuzana Krejčová
Modified: 2016-08-01 01:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-13 14:53:10 UTC
Type: Bug


Attachments (Terms of Use)
repo with example b.rule, model, enum and dsl config. (266.81 KB, application/xml)
2011-08-31 13:11 UTC, Zuzana Krejčová
no flags Details

Description Zuzana Krejčová 2011-08-31 13:11:43 UTC
Created attachment 520816 [details]
repo with example b.rule, model, enum and dsl config.

Description of problem:
In a business rule, you can add some dsl sentence from a dsl configuration. If that sentence uses dependent enumerations, only the "main" field, the one on which others depend, has its values listed. The depending values are not shown, the listBox is not populated form the enumeration and contains only "Choose...".


Version-Release number of selected component (if applicable):
BRMS 5.2.0 ER3


Additional info:
Dependent enumerations work as intended when used via declarative model.

Comment 1 manstis 2011-09-13 12:11:49 UTC
This is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=724529, which has been fixed.

Comment 2 Tihomir Surdilovic 2011-09-13 14:53:10 UTC

*** This bug has been marked as a duplicate of bug 724529 ***

Comment 3 lcarlon 2011-09-15 05:32:03 UTC
Marked as not needing a release note as this is a duplicate of bug 724529 which has a release note.


Note You need to log in before you can comment on or make changes to this bug.