Bug 734808 - [cups] gs crash
Summary: [cups] gs crash
Keywords:
Status: CLOSED DUPLICATE of bug 643105
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ghostscript
Version: 6.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Tim Waugh
QA Contact: i18n Engineering List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-31 14:22 UTC by Tim Waugh
Modified: 2011-09-02 10:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-02 10:56:02 UTC


Attachments (Terms of Use)

Description Tim Waugh 2011-08-31 14:22:55 UTC
Created attachment 520829 [details]
ZEBRA-workaround.ppd

Description of problem:
The CUPS pstoraster filter can crash on some input.

Version-Release number of selected component (if applicable):
ghostscript-8.70-11.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.PPD=ZEBRA-workaround.ppd gs -dQUIET -dDEBUG -dPARANOIDSAFER -dNOPAUSE -dBATCH -dNOMEDIAATTRS -sDEVICE=cups -sstdout=/dev/null -sOUTPUTFILE=/dev/null pstops.ps
  
Actual results:
*** glibc detected *** gs: malloc(): memory corruption: 0x00000000027fcd20 ***

Expected results:
Normal program exit.

Additional info:
Attachments derived from bug #734764.

Comment 2 Tim Waugh 2011-08-31 14:25:04 UTC
Attachments are actually derived from bug #733524.  bug #734764 is not relevant.

Comment 3 Tim Waugh 2011-08-31 14:25:46 UTC
I wasn't able to reproduce this on unpatched ghostscript-8.70.

Comment 5 Tim Waugh 2011-08-31 14:54:14 UTC
I wasn't able to reproduce this with ghostscript-8.70-6.el6.x86_64 -- in other words, this is not a regression compared to Red Hat Enterprise Linux 6.0.

Comment 6 RHEL Product and Program Management 2011-08-31 14:58:11 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 7 Tim Waugh 2011-09-02 10:56:02 UTC
This issue is another aspect of bug #643105.

*** This bug has been marked as a duplicate of bug 643105 ***


Note You need to log in before you can comment on or make changes to this bug.