Bug 734886 - regression in /usr/sbin/tomcat6 (Additionally Created Instances of Tomcat are broken / don't work)
Summary: regression in /usr/sbin/tomcat6 (Additionally Created Instances of Tomcat are...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: tomcat6
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: David Knox
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-31 18:46 UTC by John Dennis
Modified: 2015-11-02 00:16 UTC (History)
7 users (show)

Fixed In Version: tomcat6-6.0.32-8.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-19 04:35:16 UTC


Attachments (Terms of Use)

Description John Dennis 2011-08-31 18:46:51 UTC
This bug was reported and fixed in bug #575341. But it has reappeared in F16 and in rawhide (e.g. master).

I presume the fix was only applied in F14 and F15 and the fix was not applied to the master branch (e.g. rawhide). Rawhide subsequently became F16 (they are different now) thus preserving the bug in both F16 and rawhide.

Why wasn't this fix applied to master when bug #575341 was fixed?

It's generally a good idea to fix things in all the branches, especially in master because that's the source from which new releases are derived from.

BTW, it's critical to get this fixed because it's breaking certificate server (i.e. dogtag) and IPA.

Comment 1 Fedora Update System 2011-08-31 20:24:54 UTC
tomcat6-6.0.32-15.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/tomcat6-6.0.32-15.fc16

Comment 2 John Dennis 2011-08-31 20:41:44 UTC
Thank you David for very promptly addressing this, much appreciated!

Comment 3 Fedora Update System 2011-08-31 21:44:33 UTC
Package tomcat6-6.0.32-15.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing tomcat6-6.0.32-15.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/tomcat6-6.0.32-15.fc16
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2011-09-21 23:47:54 UTC
tomcat6-6.0.32-16.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/tomcat6-6.0.32-16.fc16

Comment 5 Fedora Update System 2011-09-27 22:24:54 UTC
tomcat6-6.0.32-8.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/tomcat6-6.0.32-8.fc15

Comment 6 Fedora Update System 2011-09-27 22:26:00 UTC
tomcat6-6.0.32-17.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/tomcat6-6.0.32-17.fc16

Comment 7 Fedora Update System 2011-10-19 04:35:16 UTC
tomcat6-6.0.32-17.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2011-10-20 09:57:24 UTC
tomcat6-6.0.32-8.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.