Bug 734888 - timeout causes misrendered pages in certain cases
Summary: timeout causes misrendered pages in certain cases
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-conductor
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
Assignee: Jan Provaznik
QA Contact: Aziza Karol
URL: https://hp-bl480c-01.rhts.eng.bos.red...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-31 18:55 UTC by wes hayutin
Modified: 2012-05-15 21:55 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-15 21:55:40 UTC


Attachments (Terms of Use)
ss (149.43 KB, image/png)
2011-08-31 18:55 UTC, wes hayutin
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:0583 normal SHIPPED_LIVE new packages: aeolus-conductor 2012-05-15 22:31:59 UTC

Description wes hayutin 2011-08-31 18:55:08 UTC
Created attachment 520880 [details]
ss

Description of problem:

1. start a deployment
2. go to the list view instances page..
3. let the cookie timeout
4. click refresh

get a misrendered  page..
see screenshot

Comment 1 wes hayutin 2011-09-28 16:39:25 UTC
making sure all the bugs are at the right version for future queries

Comment 3 wes hayutin 2012-01-12 16:51:35 UTC
adding to sprint tracker

Comment 4 Angus Thomas 2012-01-12 17:42:39 UTC
Hi Jan.

Could you please attempt to reproduce this?

Comment 5 Jan Provaznik 2012-01-13 13:15:00 UTC
This doesn't happen anymore. Probably because we switched to backbone:
if the session cookie expires (user is unauthenticated) a message "You must be logged in to view this page" is returned with code 200 (I think code should be different but it's not related to this). Page is just not being updated now.

The fact that page is not being updated w/o displaying any message if an error occurs should be covered by bug https://bugzilla.redhat.com/show_bug.cgi?id=746650.

Comment 6 Jan Provaznik 2012-01-13 13:28:17 UTC
Here is a ticket for wrong http status code being returned for unauthenticated requests: https://bugzilla.redhat.com/show_bug.cgi?id=781450

Comment 7 Aziza Karol 2012-01-17 07:07:56 UTC
This issue does not occur any more.

verified on:
rpm -qa | grep aeolus
aeolus-conductor-doc-0.8.0-7.el6.noarch
rubygem-aeolus-image-0.3.0-2.el6.noarch
rubygem-aeolus-cli-0.3.0-3.el6.noarch
aeolus-all-0.8.0-7.el6.noarch
aeolus-conductor-0.8.0-7.el6.noarch
aeolus-configure-2.5.0-4.el6.noarch
aeolus-conductor-daemons-0.8.0-7.el6.noarch

Comment 9 errata-xmlrpc 2012-05-15 21:55:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0583.html


Note You need to log in before you can comment on or make changes to this bug.