Bug 734904 - causes gnome-shell to crash when enabled
Summary: causes gnome-shell to crash when enabled
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell-extension-icon-manager
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Guillaume Kulakowski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-31 20:03 UTC by Alex Lancaster
Modified: 2011-11-09 06:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-09 06:54:11 UTC


Attachments (Terms of Use)
.xsession-errors with gnome-shell-extension-icon-manager installed (2.30 KB, application/octet-stream)
2011-10-06 19:01 UTC, Scott J Henson
no flags Details

Description Alex Lancaster 2011-08-31 20:03:13 UTC
When I added this extension and restarted, it caused gnome-shell to crash.  I lost ~/.xsession-errors that had the console output, but I'll try reproduce it and send the error file.  Just filing now in case this is a known problem.

Comment 1 Alex Lancaster 2011-08-31 20:04:40 UTC
Btw, when I removed the extension using "yum remove" and restarted, no crash.

Comment 2 Guillaume Kulakowski 2011-09-01 08:31:56 UTC
Can't reproduice.

Can you post more informations ?
rpm -qa | grep gnome-shell
uname -a
etc.

Comment 3 Guillaume Kulakowski 2011-09-01 16:34:55 UTC
Try the last build : http://koji.fedoraproject.org/koji/buildinfo?buildID=261620

Comment 4 Scott J Henson 2011-10-06 18:52:44 UTC
I can reproduce this bug. Trying the new version now.

Comment 5 Scott J Henson 2011-10-06 19:00:34 UTC
Reproduced failure. Attached xsession-errors. It seems that we are missing a schema key.

Comment 6 Scott J Henson 2011-10-06 19:01:27 UTC
Created attachment 526774 [details]
.xsession-errors with gnome-shell-extension-icon-manager installed

Comment 7 Scott J Henson 2011-10-06 20:59:07 UTC
After some digging, it seems like the desaturation-factor key isn't surfacing right. 


gsettings get org.gnome.shell.extensions.icon-manager desaturation-factor
No such key 'desaturation-factor'

I looked at it in dconf-editor, and it seemed to see it just fine. Not sure what is going on here, but it looks like dconf has gone split brain?

Comment 8 Jonathan Kamens 2011-10-07 16:06:27 UTC
How did you add the extension in the first place? When I install the RPM and restart gnome-shell, it still doesn't show up as being available for activation in gnome-tweak-tool.

Comment 9 Guillaume Kulakowski 2011-11-05 11:18:00 UTC
Solved in the last version ?

Comment 10 Alex Lancaster 2011-11-08 23:40:20 UTC
Seems to be fixed now (at least in f16).  No crash if enabled.  Haven't retested on my other f15 machine as yet.


Note You need to log in before you can comment on or make changes to this bug.