Bug 734911 - [abrt] clementine-0.7.1-1.fc14: Process /usr/bin/clementine was killed by signal 4 (SIGILL)
Summary: [abrt] clementine-0.7.1-1.fc14: Process /usr/bin/clementine was killed by sig...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: orc
Version: 14
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fabian Deutsch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:2a2ebf0e26f3c1f34603ba0f804...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-31 20:18 UTC by david
Modified: 2011-10-13 00:49 UTC (History)
3 users (show)

Fixed In Version: orc-0.4.16-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-13 00:49:59 UTC


Attachments (Terms of Use)
File: backtrace (113.69 KB, text/plain)
2011-08-31 20:18 UTC, david
no flags Details

Description david 2011-08-31 20:18:37 UTC
abrt version: 1.1.18
architecture: i686
Attached file: backtrace, 116420 bytes
cmdline: /usr/bin/clementine
component: clementine
Attached file: coredump, 186253312 bytes
crash_function: orc_x86_emit_modrm_memoffset@plt
executable: /usr/bin/clementine
kernel: 2.6.35.14-95.fc14.i686
package: clementine-0.7.1-1.fc14
rating: 4
reason: Process /usr/bin/clementine was killed by signal 4 (SIGILL)
release: Fedora release 14 (Laughlin)
time: 1314804881
uid: 500

How to reproduce
-----
1. Run Clementine
2. Try to add files to playlist or plugged in device.
3. .*BOOM*.

Comment 1 david 2011-08-31 20:18:39 UTC
Created attachment 520887 [details]
File: backtrace

Comment 2 Orcan Ogetbil 2011-08-31 21:04:18 UTC
Thanks for the report. I think this is because orc was compiled with sse support on i686 and your machine is too old to handle this. 

I am not sure if orc is supposed to be compiled with sse on i686 architecture. orc maintainers might have a better idea. Assigning to orc.

Comment 3 Fabian Deutsch 2011-10-01 19:28:32 UTC
Did this problema ppear again?
If so, could you try to update to orc in updates-testing following the instructions here:
https://bugzilla.redhat.com/show_bug.cgi?id=741228#c3

Comment 4 David Schleef 2011-10-03 03:34:01 UTC
This was likely fixed in 0.4.15.  It matches other backtraces that were fixed.

Comment 5 Fedora Update System 2011-10-03 14:01:32 UTC
orc-0.4.16-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/orc-0.4.16-1.fc15

Comment 6 Fedora Update System 2011-10-03 14:02:08 UTC
orc-0.4.16-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/orc-0.4.16-1.fc14

Comment 7 Fedora Update System 2011-10-03 23:56:02 UTC
Package orc-0.4.16-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing orc-0.4.16-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/orc-0.4.16-1.fc15
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2011-10-13 00:49:59 UTC
orc-0.4.16-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.