Bug 734969 - Server crashes when switching ScreenRecs with PointerKeys
Summary: Server crashes when switching ScreenRecs with PointerKeys
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Peter Hutterer
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 743047
TreeView+ depends on / blocked
 
Reported: 2011-09-01 00:42 UTC by Peter Hutterer
Modified: 2011-12-06 14:38 UTC (History)
1 user (show)

Fixed In Version: xorg-x11-server-1.10.4-2.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 14:38:59 UTC


Attachments (Terms of Use)
example xorg.conf (1.37 KB, text/plain)
2011-09-01 00:44 UTC, Peter Hutterer
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:1602 normal SHIPPED_LIVE xorg-x11-server and tigervnc bug fix and enhancement update 2011-12-06 00:51:12 UTC

Description Peter Hutterer 2011-09-01 00:42:31 UTC
Version-Release number of selected component (if applicable):
xorg-x11-server-1.10.3-6.el6

How reproducible:
User PointerKeys to move between screens.

Steps to Reproduce:
1. Use multi-head xorg.conf such as the one attached. Not RandR, it has to be different screen sections
2. Enable PointerKeys: setxkbmap -option "keypad:pointerkeys"
3. Activate PointerKeys by pressing Shift + NumLock
4. Move cursor with keypad 4 or 6 across the screen boundary
5. Boom!
  
Additional info:
QA: this requires ati or nvidia cards to reproduce, afaik the intel driver does not support this configuration so the bug cannot be triggered.

Comment 1 Peter Hutterer 2011-09-01 00:44:48 UTC
Created attachment 520927 [details]
example xorg.conf

Comment 3 RHEL Product and Program Management 2011-09-02 00:19:37 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.

Comment 5 Peter Hutterer 2011-09-08 03:43:15 UTC
MODIFIED

xorg-x11-server-1.10.4-2.el6 is available in brew

Comment 9 errata-xmlrpc 2011-12-06 14:38:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1602.html


Note You need to log in before you can comment on or make changes to this bug.