Bug 735011 - virsh hang up with autodestroy domains after doing save operation fail
Summary: virsh hang up with autodestroy domains after doing save operation fail
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.2
Hardware: Unspecified
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Osier Yang
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 733806
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-01 07:29 UTC by Nan Zhang
Modified: 2014-03-27 01:03 UTC (History)
9 users (show)

Fixed In Version: libvirt-0.9.4-8.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 11:27:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1513 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2011-12-06 01:23:30 UTC

Description Nan Zhang 2011-09-01 07:29:57 UTC
Description of problem:
Start a guest with autodestroy option, libvirt will hang up with any virsh command after doing save operation fail.

Version-Release number of selected component (if applicable):
libvirt-0.9.4-7.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
# virsh
Welcome to virsh, the virtualization interactive terminal.

Type:  'help' for help with commands
          'quit' to quit

virsh # start foo --autodestroy
Domain foo started

virsh # save foo /tmp/foo
error: Failed to save domain foo to /tmp/foo
error: Requested operation is not valid: domain is marked for auto destroy

virsh # list

(hang up with 'list' command)

Actual results:
Hang up with any virsh command.

Expected results:
virsh should not hang up.

Additional info:

Comment 2 Nan Zhang 2011-09-01 07:45:48 UTC
Set Keywords with Regression, since it's not reproduced in libvirt-0.9.4-6.el6.x86_64.

Comment 4 Daniel Veillard 2011-09-01 08:14:20 UTC
Very simple fix, the bug was introduced in the patch for #733806
it's a trivial one line fix,

Daniel

Comment 7 yuping zhang 2011-09-07 07:24:28 UTC
Verify this issue with :
libvirt-0.9.4-9.el6.x86_64
qemu-kvm-0.12.1.2-2.185.el6.x86_64

# virsh 
Welcome to virsh, the virtualization interactive terminal.

Type:  'help' for help with commands
       'quit' to quit

virsh # start rhel6 --autodestroy
Domain rhel6 started

virsh # save rhel6 rhel6.save
error: Failed to save domain rhel6 to rhel6.save
error: Requested operation is not valid: domain is marked for auto destroy

virsh # list 
 Id Name                 State
----------------------------------
  3 rhel6                running

virsh # exit


# /etc/init.d/libvirtd status
libvirtd (pid  11948) is running...

So change the status to VERIFIED.

Comment 8 errata-xmlrpc 2011-12-06 11:27:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1513.html


Note You need to log in before you can comment on or make changes to this bug.