Bug 735091 - pulp-server fails to init/restart without pulp-admin
Summary: pulp-server fails to init/restart without pulp-admin
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Pulp
Classification: Retired
Component: rel-eng
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: Sprint 30
Assignee: Jeff Ortel
QA Contact: Preethi Thomas
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-01 12:41 UTC by Preethi Thomas
Modified: 2012-02-24 20:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-24 20:16:38 UTC


Attachments (Terms of Use)
Reproduce Log (17.72 KB, text/plain)
2011-09-07 14:17 UTC, Jeff Ortel
no flags Details

Description Preethi Thomas 2011-09-01 12:41:08 UTC
Description of problem:

[root@pulp-f15 ~]# service pulp-server init
Starting mongod (via systemctl):                           [  OK  ]
/etc/init.d/pulp-server: line 28: /usr/bin/pulp-migrate: No such file or directory
[root@pulp-f15 ~]# yum install pulp-admin
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package pulp-admin.noarch 0:0.0.229-1.fc15 will be installed
--> Processing Dependency: pulp-client-lib = 0.0.229 for package: pulp-admin-0.0.229-1.fc15.noarch
--> Running transaction check
---> Package pulp-client-lib.noarch 0:0.0.229-1.fc15 will be installed
--> Processing Dependency: gofer >= 0.45 for package: pulp-client-lib-0.0.229-1.fc15.noarch
--> Running transaction check
---> Package gofer.noarch 0:0.47-1.fc15 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package            Arch      Version              Repository              Size
================================================================================
Installing:
 pulp-admin         noarch    0.0.229-1.fc15       testing-fedora-pulp    147 k
Installing for dependencies:
 gofer              noarch    0.47-1.fc15          testing-fedora-pulp     53 k
 pulp-client-lib    noarch    0.0.229-1.fc15       testing-fedora-pulp    133 k

Transaction Summary
================================================================================
Install       3 Package(s)

Total download size: 333 k
Installed size: 1.0 M
Is this ok [y/N]: y
Downloading Packages:
(1/3): gofer-0.47-1.fc15.noarch.rpm                      |  53 kB     00:00     
(2/3): pulp-admin-0.0.229-1.fc15.noarch.rpm              | 147 kB     00:00     
(3/3): pulp-client-lib-0.0.229-1.fc15.noarch.rpm         | 133 kB     00:00     
--------------------------------------------------------------------------------
Total                                           106 kB/s | 333 kB     00:03     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : gofer-0.47-1.fc15.noarch                                     1/3 
  Installing : pulp-client-lib-0.0.229-1.fc15.noarch                        2/3 
  Installing : pulp-admin-0.0.229-1.fc15.noarch                             3/3 

Installed:
  pulp-admin.noarch 0:0.0.229-1.fc15                                            

Dependency Installed:
  gofer.noarch 0:0.47-1.fc15       pulp-client-lib.noarch 0:0.0.229-1.fc15      

Complete!
[root@pulp-f15 ~]# vi /etc/pulp/admin/admin.conf
[root@pulp-f15 ~]# service pulp-server init
Starting mongod (via systemctl):                           [  OK  ]
data model in use matches the current version
database migration to version 22 complete
[root@pulp-f15 ~]#

Comment 1 Preethi Thomas 2011-09-02 14:32:37 UTC
on rhel5

[root@pulp-qe-rhel5 ~]# service pulp-server init
Starting mongod:                                           [  OK  ]
Traceback (most recent call last):
  File "/usr/bin/pulp-migrate", line 19, in ?
    from pulp.server.db.migrate import script
  File "/root/pulp/src/pulp/server/db/migrate/script.py", line 20, in ?
    from pulp.server import auditing
  File "/root/pulp/test/unit/../../src/pulp/server/auditing.py", line 33, in ?
    from pulp.server import async
  File "/root/pulp/test/unit/../../src/pulp/server/async.py", line 19, in ?
    from gofer.messaging.async import ReplyConsumer, Listener
ImportError: No module named async

Comment 2 Jeff Ortel 2011-09-02 15:44:22 UTC
This looks like old pulp code.  Can you verify this is the latest version?

Comment 3 Jeff Ortel 2011-09-02 16:07:38 UTC
The problem is that you have a pulp checkout in /root/pulp which is in the python path:

>>> for p in sys.path:
...   print p
... 

/root/pulp/src
/usr/lib64/python24.zip
/usr/lib64/python2.4
/usr/lib64/python2.4/plat-linux2
/usr/lib64/python2.4/lib-tk
/usr/lib64/python2.4/lib-dynload
/usr/lib64/python2.4/site-packages
/usr/lib64/python2.4/site-packages/Numeric
/usr/lib64/python2.4/site-packages/gtk-2.0
/usr/lib/python2.4/site-packages

mv /root/pulp to something else like /root/_pulp and it works.

Comment 4 Jeff Ortel 2011-09-02 18:15:58 UTC
pulp-migrate moved to main 'pulp' rpm.

Comment 5 Jeff Ortel 2011-09-02 19:18:12 UTC
build: 0.230

Comment 6 Preethi Thomas 2011-09-06 15:05:02 UTC
Fails_qa

From ssl_error_log

[Tue Sep 06 11:29:33 2011] [error] [client 127.0.0.1] Certificate Verification: Error (10): certificate has expired
[Tue Sep 06 11:29:33 2011] [error] [client 127.0.0.1] Re-negotiation handshake failed: Not accepted by client!?

After pulp-admin is installed

[Tue Sep 06 11:59:49 2011] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Tue Sep 06 11:59:49 2011] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)

Comment 7 Jeff Ortel 2011-09-07 14:17:12 UTC
Created attachment 521903 [details]
Reproduce Log

Log of efforts to reproduce.

Comment 8 dgao 2011-10-03 14:15:39 UTC
Spotted this in /var/log/messages


Oct  2 03:06:02 pulp-nightly rsyslogd: [origin software="rsyslogd" swVersion="5.7.9" x-pid="576" x-info="http://www.rsyslog.com"] rsyslogd was HUPed
Oct  2 03:06:03 pulp-nightly qpidd[30827]: 2011-10-02 03:06:03 error Execution exception: resource-locked: Queue pulp.task has an exclusive consumer. No more consumers allowed. (qpid/broker/Queue.c
pp:385)
Oct  2 03:21:56 pulp-nightly qpidd[30827]: 2011-10-02 03:21:56 warning LinkRegistry task late 3 times by 665ms on average.
Oct  2 03:22:02 pulp-nightly qpidd[30827]: 2011-10-02 03:22:02 warning LinkRegistry task late 3 times by 212ms on average.
Oct  2 03:22:02 pulp-nightly qpidd[30827]: 2011-10-02 03:22:02 warning ManagementAgent::periodicProcessing task late 1 times by 52ms on average.
Oct  2 03:22:08 pulp-nightly qpidd[30827]: 2011-10-02 03:22:08 warning LinkRegistry task late 2 times by 599ms on average.
Oct  2 03:22:13 pulp-nightly qpidd[30827]: 2011-10-02 03:22:13 warning LinkRegistry task late 1 times by 1665ms on average.

This may be related to the rsyslog daemon screwing up qpidd.

Comment 9 Jeff Ortel 2011-11-10 14:11:21 UTC
Added:

export SYSTEMCTL_IGNORE_DEPENDENCIES=1

To both: pulp-server and pulp-cds scripts.

Comment 10 Jeff Ortel 2011-11-10 14:13:11 UTC
Cut-n-paste error in #9.  Actually added:  'export SYSTEMCTL_SKIP_REDIRECT=1'

Comment 11 Jeff Ortel 2011-11-11 18:48:01 UTC
build: 0.248

Comment 12 dgao 2011-11-11 22:01:47 UTC
[root@pulp-qe ~]# rpm -qa | grep "pulp-admin"
[root@pulp-qe ~]# service pulp-server init
data model in use matches the current version
database migration to version 29 complete

Comment 13 Preethi Thomas 2012-02-24 20:16:38 UTC
Pulp v1.0 is released
Closed Current Release.

Comment 14 Preethi Thomas 2012-02-24 20:17:54 UTC
Pulp v1.0 is released.


Note You need to log in before you can comment on or make changes to this bug.