Bug 735314 - Not possible to compile compat-wireless due to how the kernel is configured
Summary: Not possible to compile compat-wireless due to how the kernel is configured
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 15
Hardware: x86_64
OS: Linux
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2011-09-02 09:43 UTC by martin
Modified: 2011-09-05 14:20 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2011-09-02 13:58:49 UTC

Attachments (Terms of Use)
Error output from make (513 bytes, text/plain)
2011-09-02 09:44 UTC, martin
no flags Details

Description martin 2011-09-02 09:43:32 UTC
Description of problem:
As I've reported in bug 735310 it's not possible for me to connect to Mobile Broadband from my laptop since I reinstalled it with Fedora 15. In Fedora 13 I had problems with the original kernel drivers that it did connect but usually had a packet loss of 70-80%  and I solved that by compiling drivers from compat-wireless which worked pretty much flawlessly.

So to solve this new problem I decided to do the same, only that it doesn't compile anymore due to changes in the kernel configs compared to Fedora 13 (and, I think, Fedora 14).

Version-Release number of selected component (if applicable):
compat-wireless 2.6.39-1
Linux (from repo)

How reproducible:

Steps to Reproduce:
1. tar -xf compat-wireless-2.6.39-1.tar.bz2
2. make
Actual results:
See attachment makefailure.txt

Expected results:
Finished compilation, installation and working drivers.

Additional info:

Comment 1 martin 2011-09-02 09:44:33 UTC
Created attachment 521197 [details]
Error output from make

Comment 2 Josh Boyer 2011-09-02 11:33:48 UTC
John, Stanislaw, any thoughts?

Comment 3 Stanislaw Gruszka 2011-09-02 13:58:49 UTC
compat-wireless does not allow to compile old drivers in newer kernels, 2.6.40 is newer than 2.6.39, so this is not valid bug.

For compiling newer compat-wirless packages, this patch is needed to handle fedora 3.0 to 2.6.40 version change:

See also

Comment 4 martin 2011-09-05 14:20:54 UTC
In case someone googles for the error message and end up here. It helps to do:

yum install kernel-devel

*ahem* *blush* Sorry 'bout that.

Haven't managed to compile it for 2.6.40 yet, but at least I've got it up and running for 2.6.38 at least, which is a hell of a lot better than no 3G at all...

Sorry for being a klutz.

Note You need to log in before you can comment on or make changes to this bug.