Bug 735362 - Compilation fails with errors in files from opencv-devel
Compilation fails with errors in files from opencv-devel
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: opencv (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Josef Ridky
BaseOS QE - Apps
: FastFix, Patch
Depends On:
Blocks: 947782 1159825 1356044
  Show dependency treegraph
 
Reported: 2011-09-02 09:28 EDT by David Jaša
Modified: 2017-09-25 03:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-25 03:59:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch to prevent compile errors (374 bytes, patch)
2011-09-23 09:35 EDT, Honza Horak
no flags Details | Diff

  None (edit)
Description David Jaša 2011-09-02 09:28:42 EDT
Description of problem:
When compiling GMIC 1.5.0.2 ( http://sourceforge.net/projects/gmic/files/ ) on RHEL 6, I'm getting these errors in opencv: http://pastebin.test.redhat.com/60260

Version-Release number of selected component (if applicable):
opencv-2.0.0-9.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
similar bug to debian's http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=562742
might be duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=632215
Comment 2 RHEL Product and Program Management 2011-09-02 09:57:54 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 3 Honza Horak 2011-09-23 09:10:59 EDT
Can you reproduce this failure with some package that is easily configurable and doesn't need non-RHEL packages like ffmpeg-libs? Or if you can provide just a little as possible piece of code as a reproducer, it would be great.

I've created a scratch build with the patch used in debian, can you try it, please?
https://brewweb.devel.redhat.com/taskinfo?taskID=3660374
Comment 4 Honza Horak 2011-09-23 09:35:59 EDT
Created attachment 524617 [details]
proposed patch to prevent compile errors

This is patch used in scratch build above.
Comment 5 Honza Horak 2011-10-18 09:19:15 EDT
Can you, please, try the proposed patch or provide a better reproducer, David?
Comment 6 David Jaša 2011-10-18 11:31:42 EDT
The proposed patch works for me, there are no errors or warnings pointing to opencv.
Comment 22 Josef Ridky 2017-09-25 03:59:47 EDT
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the
Production 3 Phase, Critical impact Security Advisories (RHSAs) and
selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as
they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase
and will be marked as CLOSED/WONTFIX. If this remains a critical
requirement, please contact Red Hat Customer Support to request
a re-evaluation of the issue, citing a clear business justification. Note
that a strong business justification will be required for re-evaluation.
Red Hat Customer Support can be contacted via the Red Hat Customer Portal
at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.