Bug 735368 - xfig complains of old app-defaults file
Summary: xfig complains of old app-defaults file
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xfig
Version: 6.0
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Stanislav Ochotnicky
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-02 13:46 UTC by cornelius.brinegar
Modified: 2012-06-12 16:18 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-12 16:18:59 UTC


Attachments (Terms of Use)

Description cornelius.brinegar 2011-09-02 13:46:05 UTC
Description of problem:
xfig complains that either an old or missing app-defaults file is being used.

Version-Release number of selected component (if applicable):
3.2.5-22.a

How reproducible:
100%

Steps to Reproduce:
1. start xfig
2.
3.
  
Actual results:
A dialog box opens with the error, and the GUI is 2D looking.

Expected results:
No dialog box, and the GUI should use the Xaw3d widgets.

Additional info:
The problem is that the app-defaults/Fig file is not where xfig wants it to be.  A work around is as follows:
cd /usr/lib
sudo mkdir X11
cd X11
sudo ln -s /usr/share/X11/app-defaults app-defaults

Comment 2 RHEL Product and Program Management 2011-09-02 14:18:03 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 3 Stanislav Ochotnicky 2011-11-01 16:31:16 UTC
I was unable to reproduce. Can you try to create a fresh user and reproduce with new account? 

Also what is your output of "rpm -q xfig"

Comment 4 cornelius.brinegar 2011-11-14 13:42:48 UTC
rpm -q xfig gives:
xfig-3.2.5-22.a.1.el6.x86_64

I removed the symbolic link in /usr/lib/X11, created a new user, and the new user's xfig works perfectly.  Unfortunately, the xfig in my user account still says it cannot find the correct app-defaults/Fig file.

I don't know what is wrong, but it may not be a "bug" in RHEL.

Comment 5 Stanislav Ochotnicky 2012-06-12 16:18:59 UTC
You most likely modified one of XFILESEARCHPATH, XUSERFILESEARCHPATH,  XAPPLRESDIR in your environment so X cannot find resources Xfig is asking for. Check your environment, possibly also ~/.Xdefaults file for changes.


Note You need to log in before you can comment on or make changes to this bug.