Bug 73538 - broken spadmin in ru_RU.UTF-8
broken spadmin in ru_RU.UTF-8
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: openoffice.org (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-05 17:19 EDT by Leonid Kanter
Modified: 2007-04-18 12:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-20 11:01:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spadmin window snapshot (8.73 KB, image/png)
2002-09-05 17:20 EDT, Leonid Kanter
no flags Details
oowriter with cyrillic text (53.40 KB, image/png)
2002-09-07 18:40 EDT, Eugene Kanter
no flags Details
openoffice.org-1.1.0 looks fine to me. (17.47 KB, image/png)
2004-02-10 18:33 EST, Sam Varshavchik
no flags Details

  None (edit)
Description Leonid Kanter 2002-09-05 17:19:11 EDT
Description of Problem:

spadmin doesn't display cyrillic characters in ru_RU.UTF-8 locale

Version-Release number of selected component (if applicable):

openoffice-1.0.1-4

How Reproducible:

always

Steps to Reproduce:
1. install null and select Russian as default language
2. login and start OpenOffice.org printer setup from menu


Actual Results:

you'll see "?" in place of every character

Expected Results:

Cyrillic text must be there

Additional Information:
	
In other OOo applications (writer, calc etc) everything is Ok
Comment 1 Leonid Kanter 2002-09-05 17:20:25 EDT
Created attachment 75134 [details]
spadmin window snapshot
Comment 2 Sam Varshavchik 2002-09-07 00:12:10 EDT
METOO.

Something's broken with ru_RU.utf8.  I can't even start oowriter

LANG=ru_RU.utf8 oowriter spins in an infinite loop.

LANG=ru_RU works, LANG=ru_RU.utf8 doesn't.

Comment 3 Eugene Kanter 2002-09-07 18:40:33 EDT
Created attachment 75428 [details]
oowriter with cyrillic text
Comment 4 Eugene Kanter 2002-09-07 18:42:46 EDT
I am able to enter Cyrillic letters in both en_US.UTF-8 and ru_RU.UTF-8 locales.
There is a small problem. In en_US.UTF-8 if file name contains Cyrillic (UTF-8)
letters, they do not show up in OO file open (and status bar). However correct
Cyrillic document name shows up in window title! See attached.
This is just null + up2date (no other packages/ajustments).
Comment 5 Leonid Kanter 2003-01-28 16:19:53 EST
This bug is still present in phoebe (8.0.93) 
Comment 6 Leonid Kanter 2003-05-27 05:26:14 EDT
If msttcorefonts rpm is instaled (see corefonts.sf.net), spadmin window is ok. 
Comment 7 Leonid Kanter 2003-09-11 03:55:27 EDT
Looks like the reason is somewhere in openoffice-default-font-nimbus-luxi.patch.
List of fonts for aImplSubsSansUnicode[] =
"andalesansui;luxisans;arialunicodems;lucidaunicode" doesn't have any font with
cyrillic glyph. If you install MS fonts, spadmin will appear in MS Arial
(arialunicodems). To fix this proble, it woluld be enough to add at leat one
sans serif font with cyrillic characters to this list, for example nimbussansl.
Comment 8 Dan Williams 2004-02-10 16:00:45 EST
Does this problem still occur with 1.0.2-8 or later?
Comment 9 Sam Varshavchik 2004-02-10 18:33:32 EST
Created attachment 97568 [details]
openoffice.org-1.1.0 looks fine to me.

I think this has been fixed some time ago.
Comment 10 Leonid Kanter 2004-02-20 10:07:56 EST
Unfortunately, I'm unable to find printer admin in currently installed
openoffice.org-1.1.0-27
Comment 11 Dan Williams 2004-02-20 10:24:59 EST
1.1.0 > 20 don't ship with an spadmin since all printers are automatically discovered 
using CUPS, and since File->Export to PDF is the correct PDF export method...  So I 
guess this has been "fixed" more or less?
Comment 12 Leonid Kanter 2004-02-20 11:01:26 EST
Yes, I marked as "closed"

Note You need to log in before you can comment on or make changes to this bug.