This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 735419 - Agents should support multiple SRV records
Agents should support multiple SRV records
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: matahari (Show other bugs)
6.2
All All
unspecified Severity medium
: rc
: ---
Assigned To: Russell Bryant
Dave Johnson
: Rebase
Depends On: 735417
Blocks: 743047
  Show dependency treegraph
 
Reported: 2011-09-02 11:26 EDT by Russell Bryant
Modified: 2011-12-06 06:42 EST (History)
2 users (show)

See Also:
Fixed In Version: matahari-0.4.4-1.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Cause: When specifying a broker to connect to, one could only specify a hostname or IP address. Consequence: Providing a list of brokers to connect to that can be updated dynamically was not possible. Change: Mataari now supports querying for DNS SRV records to determine the broker, or list of brokers to attempt to connect to. Result: Administrators can now use DNS SRV to control where Matahari agents connect to.
Story Points: ---
Clone Of: 735417
Environment:
Last Closed: 2011-12-06 06:42:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Russell Bryant 2011-09-02 11:26:16 EDT
+++ This bug was initially created as a clone of Bug #735417 +++

Description of problem:

The current DNS SRV support in Matahari agents only works as expected if there is only a single DNS SRV record.  They do not support connection attempts to more than one.


Version-Release number of selected component (if applicable):

0.4.3
Comment 2 Russell Bryant 2011-09-07 15:16:42 EDT
This has been addressed in a few upstream commits, starting with this one:

https://github.com/matahari/matahari/commit/cc2edca53821c5b1d0401076e298322b166d8106
Comment 4 Dave Johnson 2011-09-13 09:56:34 EDT
good 2 go in v0.4.2-2

[root@agent ~]# /usr/sbin/matahari-qmf-networkd -vvv
mh_hostname: Got hostname: agent.test.com
mh_dnsdomainname: Got dnsdomainname: 'test.com'
mh_connect: SRV query successful: _matahari._tcp.test.com
mh_connect: Trying: amqp:tcp:broker1.test.com:49000
mh_connect: Trying: amqp:tcp:broker2.test.com:49000
mh_connect: Trying: amqp:tcp:broker.test.com:49000
mh_os_uuid: Got uuid: ce76da54cbe7c1d9ed1d44ce00000023
mh_hostname: Got hostname: agent.test.com
mh_hostname: Got hostname: agent.test.com
mh_os_uuid: Got uuid: ce76da54cbe7c1d9ed1d44ce00000023
mainloop_add_qmf: Added source: 1
run: Starting agent mainloop
Comment 5 Russell Bryant 2011-11-16 17:12:19 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: When specifying a broker to connect to, one could only specify a hostname or IP address.
Consequence: Providing a list of brokers to connect to that can be updated dynamically was not possible.
Change: Mataari now supports querying for DNS SRV records to determine the broker, or list of brokers to attempt to connect to.
Result: Administrators can now use DNS SRV to control where Matahari agents connect to.
Comment 6 errata-xmlrpc 2011-12-06 06:42:48 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1569.html

Note You need to log in before you can comment on or make changes to this bug.