Bug 735511 - ^C and ^Z don't work while bodhi-client prompts for passwords
Summary: ^C and ^Z don't work while bodhi-client prompts for passwords
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: bodhi
Version: 14
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Luke Macken
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-02 20:55 UTC by Garrett Holmstrom
Modified: 2016-09-20 02:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-25 16:02:19 UTC


Attachments (Terms of Use)

Description Garrett Holmstrom 2011-09-02 20:55:03 UTC
Description of problem:
^C and ^Z don't seem to work as expected (or do anything at all) while /usr/bin/bodhi waits for one to type in a password.

Version-Release number of selected component (if applicable):
bodhi-client-0.8.0-1.fc14.noarch
python-fedora-0.3.24-1.fc14.noarch

How reproducible:
Always

Steps to Reproduce:
1. Run ``bodhi --list-overrides''
2. Press ^C or ^Z when it prompts for a password
  
Actual results:
Another password prompt

Expected results:
Program termination/suspension

Comment 1 Luke Macken 2011-10-25 16:02:19 UTC
I cannot reproduce this issue with bodhi v0.8.3. Please re-open this bug if you still experience this problem. Thanks!

→ bodhi --list-overrides
Password for lmacken: 
[1]+  Stopped                 bodhi --list-overrides
→ fg
bodhi --list-overrides
^CTraceback (most recent call last):
  File "/usr/bin/bodhi", line 519, in <module>
    main()
  File "/usr/bin/bodhi", line 508, in main
    bodhi.password = getpass('Password for %s: ' % opts.username)
  File "/usr/lib64/python2.7/getpass.py", line 71, in unix_getpass
    passwd = _raw_input(prompt, stream, input=input)
  File "/usr/lib64/python2.7/getpass.py", line 133, in _raw_input
    line = input.readline()
KeyboardInterrupt


Note You need to log in before you can comment on or make changes to this bug.