Bug 73553 - RFE: configure multiple resoulution depths
RFE: configure multiple resoulution depths
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-xfree86 (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-05 22:09 EDT by Chris Kloiber
Modified: 2014-06-18 05:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 12:23:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Kloiber 2002-09-05 22:09:45 EDT
Description of Problem:

When setting up XFree86 for the hardware certification test suite, XFree86 must
be configured to run X at the highest possible resolution in each of the three
available bit depths (8,16,24). The current implimentation of
redhat-config-xfree86 will only set up one bit depth at a time. Can you add a
command line option to it that will allow you to set up resolutions in all three
bit depths at once, (a-la Xconfigurator) or perhaps an option to simply write a
config file that defaults to 16 bit depth, but has Modes lines for 1600x1200 in
all bit depths (to heck with it all, let X sort out the highest resolution that
works). Thanks.
Comment 1 Alexander Larsson 2002-09-06 04:30:52 EDT
At the moment, perhaps you can do this by calling r-c-x several times with
different --set-depth. But it would be nice to do by default.
Comment 2 Brian "netdragon" Bober 2003-01-13 19:38:18 EST
This summary is not very descriptive. Can it be improved?
Comment 3 Brent Fox 2003-01-14 17:47:33 EST
This may not be relevant once we have Xrandr.
Comment 4 Mike A. Harris 2003-01-15 02:31:56 EST
RandR is irrelevant here.  RandR allows you to change the resolution on the
fly, and does not allow you to change the depth on the fly.

What Chris is requesting, is that when the list of Modes is written to the
config file, that it be written for all 3 depths simultaneously, regardless
of which depth is set to the Default.

All of our previous config tools do this, as do other config tools.  This
allows the user to simply change the "DefaultDepth" in the config file, either
by hand, or even in the tool itself, and then restart the X server.  It also
allows the user to start up XFree86 with the -depth commandline option to
override the default depth.  If we only configure one depth, then the
-depth commandline option is rather useless.  Since XFree86 can not change
the depth on the fly, and is most likely never going to be able to do so
since RandR plans have dropped the idea of on the fly depth changing, this
capability in our config tool is fairly IMHO important.

It's a rather trivial change to make, which could be done in one of two ways.

First way:
Regardless of which depth the user has chosen to be default, write out
the "Modes" line for all 3 depths (8/16/24), or perhaps even all 4 depths
(8/15/16/24) - although not many people use depth 15, so perhaps it is
irrelevant.  This would be trivial to do.  Simple cut and paste of a 
few lines of code likely.

Second way:
Same as above, only if using a default depth of 8 or 16, ensure that when
the 24 depth is added, that the amount of video memory on the card can
handle the highest mode chosen.  If not, then remove the modes on the
higher depths one at a time to ensure the card can accomodate the mode.
This also ensures that if a user sets default to 16 on a low memory card,
if they use 24 later, the X server wont drop the mode due to lack of RAM,
and then screw them with a virtual resolution.

Let me know if you need any more help adding this, and I'll try to clarify
any other issues.

TTYL
Comment 5 Bill Nottingham 2006-08-07 14:59:37 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 6 Bill Nottingham 2006-10-18 12:23:17 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.