Bug 735536 - [Cantiga] Wrong monitor detection with Intel GM45 chipset
Summary: [Cantiga] Wrong monitor detection with Intel GM45 chipset
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: 15
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: [cat:rendering]
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-03 07:52 UTC by Franco Bugnano
Modified: 2018-04-11 07:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-13 14:13:08 UTC


Attachments (Terms of Use)
Xorg log file of the Fedora 15 Live session (25.16 KB, text/plain)
2011-09-05 18:47 UTC, Franco Bugnano
no flags Details
/var/log/messages of the Fedora 15 Live session (75.10 KB, text/plain)
2011-09-05 18:49 UTC, Franco Bugnano
no flags Details
dmesg output of the Fedora 15 Live session (123.03 KB, text/plain)
2011-09-05 18:50 UTC, Franco Bugnano
no flags Details
Xorg log file of the Fedora 14 Live session (76.80 KB, text/plain)
2011-09-05 19:05 UTC, Franco Bugnano
no flags Details
/var/log/messages of the Fedora 14 Live session (74.75 KB, text/plain)
2011-09-05 19:06 UTC, Franco Bugnano
no flags Details
dmesg output of the Fedora 14 Live session (120.11 KB, text/plain)
2011-09-05 19:06 UTC, Franco Bugnano
no flags Details

Description Franco Bugnano 2011-09-03 07:52:24 UTC
Description of problem:
I have an AOpen MP45-DR PC, which is a desktop PC with the mobile version of the GM45 chipset.
Being a desktop PC, the only monitor connected to it is the one connected to the DVI port.

In Fedora 15 (and 16 Alpha) the driver sees that the chipset is a mobile one, so it thinks it is a Laptop, and it detects 2 monitors:
1. Laptop
2. The monitor connected to the DVI port.
And it sets the non existent Laptop monitor as the primary one.

As a consequence, I cannot login to gdm, because the login screen is shown on the non existent monitor.

This bug was there also in the Fedora 11 release, but got fixed in the Fedora 12 Alpha, and it worked well up to Fedora 14.



How reproducible:
Always

Steps to Reproduce:
1. Power On
  
Actual results:
The only thing that is seen on the only monitor connected to the PC is the gdm background, as the driver thinks it is the secondary monitor.

Expected results:
The driver correctly detects that there is only one monitor connected to the PC, and it uses it as the primary (and only) monitor.

Comment 1 Matěj Cepl 2011-09-04 00:33:38 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log*; check with grep Backtrace /var/log/Xorg* which logs might be the most interesting ones, send us at least Xorg.0.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 2 Franco Bugnano 2011-09-05 18:47:58 UTC
Created attachment 521533 [details]
Xorg log file of the Fedora 15 Live session

Comment 3 Franco Bugnano 2011-09-05 18:49:26 UTC
Created attachment 521534 [details]
/var/log/messages of the Fedora 15 Live session

Comment 4 Franco Bugnano 2011-09-05 18:50:00 UTC
Created attachment 521535 [details]
dmesg output of the Fedora 15 Live session

Comment 5 Franco Bugnano 2011-09-05 19:05:32 UTC
Created attachment 521539 [details]
Xorg log file of the Fedora 14 Live session

Comment 6 Franco Bugnano 2011-09-05 19:06:04 UTC
Created attachment 521540 [details]
/var/log/messages of the Fedora 14 Live session

Comment 7 Franco Bugnano 2011-09-05 19:06:37 UTC
Created attachment 521542 [details]
dmesg output of the Fedora 14 Live session

Comment 8 Franco Bugnano 2011-09-05 19:07:25 UTC
Ok, I have attached both the non working Fedora 15 files and the working Fedora 14 files for comparison

Comment 9 Adam Jackson 2011-10-13 14:13:08 UTC
Nothing we can really do about this, Intel doesn't have any way of reliably detecting whether LVDS or eDP is attached so we have to assume it is.  We keep looking for reliable heuristics and they keep not working.

Workaround is to boot with 'video=LVDS-1:d' on the kernel command line to disable the phantom LVDS output.

Comment 10 Franco Bugnano 2011-10-15 18:39:02 UTC
The workaround works like a charm, thank you very much.

I propose to document both this bug and its workaround in the list of known bugs.


Note You need to log in before you can comment on or make changes to this bug.