Bug 735601 - No data copied to a separate boot partition when using LiveCD
Summary: No data copied to a separate boot partition when using LiveCD
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-03 22:16 UTC by Marcin Zajaczkowski
Modified: 2011-09-09 20:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-09 20:40:50 UTC


Attachments (Terms of Use)

Description Marcin Zajaczkowski 2011-09-03 22:16:00 UTC
Description of problem:
Separate boot partition is empty after Fedora 16 Beta TC1 installation from LiveCD.
If this is not supported in LiveCD mode (due to copying image) anaconda should warn user about that.

Version-Release number of selected component (if applicable):
16.16.1 ? (from Fedora 16 Beta TC1 LiveCD)

How reproducible:
Always

Steps to Reproduce:
1. Install to Hard Drive from LiveCD.
2. Select separate boot partition (custom layout)
3. Proceed installation
  
Actual results:
empty boot partition; grub files, kernel images, etc. in boot directory on root partition

Expected results:
grub files, kernel images, etc. on boot partition

Comment 1 Brian Lane 2011-09-06 22:50:14 UTC
This should work. The doFilesystemMangling function in livecd.py handles this.

Please attach the logs from /tmp/*log to this bug as individual plain/text files. Also attach /var/log/messages

Comment 2 Marcin Zajaczkowski 2011-09-09 20:40:50 UTC
I have already installed a system from netinstall. If you say that it's implemented and should work then it's possible that I did some mistake when checking partitions. I propose to close this bug report. By the time of next system installation I will try use that feature and reopen this issue if needed.


Note You need to log in before you can comment on or make changes to this bug.