Bug 735616 - NTrig Duosense isn't recognized (module wont load) in F15/16 on XPS 15.
Summary: NTrig Duosense isn't recognized (module wont load) in F15/16 on XPS 15.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 16
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-09-04 08:09 UTC by Luke Martinez
Modified: 2011-09-13 13:28 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-13 13:28:39 UTC


Attachments (Terms of Use)
dmesg (376 bytes, text/plain)
2011-09-04 08:09 UTC, Luke Martinez
no flags Details
Command: xinput -list (1002 bytes, application/octet-stream)
2011-09-04 08:09 UTC, Luke Martinez
no flags Details

Description Luke Martinez 2011-09-04 08:09:16 UTC
Created attachment 521362 [details]
dmesg

Description of problem:
NTrig Duosense isn't recognized in Fedora 15 & Fedora 16.

At boot I see the attached DMESG, and I can't find it in my xinput list. While this should have been handled by hid-ntrig.

The exact same problem is apparent in ubuntu: But the patch is a .deb.

https://bugs.launchpad.net/ubuntu/+source/utouch/+bug/724831


Version-Release number of selected component (if applicable):
hid-ntrig

How reproducible:
Always (with DELL XPS 15)

Steps to Reproduce:
1.Boot XPS 15 with Fedora 15 - 16.
2.View message on startup
3.Observe the lack of 'xinput -list'
  
Actual results:
No input in 
Xinput -list (see attached)

Expected results:
Being recognized in Xinput.

Additional info:

Comment 1 Luke Martinez 2011-09-04 08:09:56 UTC
Created attachment 521363 [details]
Command: xinput -list

Comment 2 Luke Martinez 2011-09-04 08:12:34 UTC
Looking around the exact same bug is reproducible on:

Lifebook T580 
Dell XPS 15z (with NTRIG)
Dell XPS 15 (with NTRIG, as stated)

I can confirm that: https://bugs.launchpad.net/ubuntu/+source/utouch/+bug/724831/+attachment/2129533/+files/hid-ntrig-dkms_1.1.5%7Etest_all.deb this patch is for the same problem in ubuntu and fixes it.

Comment 3 Josh Boyer 2011-09-06 16:09:09 UTC
Whatever is included in that .deb is a rather large departure from what is in the upstream kernel.  It also seems to be based against 2.6.38.  If/when those changes get pushed upstream, then your problem should be resolved.  At the moment, we can't carry anything from it as-is.

Comment 4 Luke Martinez 2011-09-07 09:42:12 UTC
Is it possible for this patch to be packaged for fedora / RHEL, I can confirm it works in the latest Ubuntu kernel, I don't particularly want to have to install ubuntu for this reason alone.

Thanks for your help,
Regards,
Luke

Comment 5 Josh Boyer 2011-09-07 11:54:15 UTC
(In reply to comment #4)
> Is it possible for this patch to be packaged for fedora / RHEL, I can confirm
> it works in the latest Ubuntu kernel, I don't particularly want to have to
> install ubuntu for this reason alone.

What Ubuntu has is not a patch.  It's a full replacement driver, and we cannot carry that in Fedora.  The best possible solution is for the changes to get pushed into the upstream driver.  I'll try emailing Canonical about their changes today to see if that is possible for them to do.

RHEL is separate from Fedora, so you would need to open a separate request against RHEL.

Comment 6 Luke Martinez 2011-09-08 05:21:34 UTC
It appears the full driver is here.

http://bitmath.org/code/hid/hid-ntrig-dkms/ it adds support for many devices.

Maybe this should be included in fedora, i haven't had success in installing it yet, i'm still trying.

Comment 7 Josh Boyer 2011-09-13 13:28:39 UTC
I've emailed Henrik Rydberg about this.  The DKMS source is separate from the in-kernel version, and while some attempts to merge them have been made none have actually succeeded.

Fedora does not carry out-of-tree drivers, so we cannot include the DKMS source.  You might try discussing this with the rpmfusion project and seeing if a kmod for it can be built.


Note You need to log in before you can comment on or make changes to this bug.